Jump to content

Dial with your iPhone from Alfred [updated to v1.41a]

Recommended Posts

  • 9 months later...



This is a really useful Workflow and thanks for creating it.


I noticed that if I enter the Prowl API Key using "dial setup", I get error message "Oops. There was a problem. Number not sent." however if I manually maintain the API key by modifying the script file then it works fine. If I enter "dial setup" again then I get below output and not sure if this is how its supposed to be:




If I manually update the api_key file and remove the text "button returned:OK," then the dialer works fine.


Also, certain phone numbers are formatted as xxx.xxx.xxxx, and dialing such numbers gives me error message "Sorry, xxx.xxx.xxxx is not a valid phone number.". Can you update the script to include such numbers too? For now I have manually added "\." identifier to the RegEx check and it does seem to be working but I am not sure if it will break anything else :-)



Edited by famaus
Link to comment
  • 1 month later...

I can't get this to work, sadly.  I'm using Alfred v2, I've set up the custom action for Contacts in the Features section as the instructions suggest, but I can't get anything to send to Prowl.  I know that the API key works because I've tested it in another application and have received the message to my phone.  Something else that I noticed is that I can't seem to get the workflow to pull the phone number out of a contact. :(


Can someone suggest how I can troubleshoot this?


Update: Edited the api_key file to get rid of the "button returned:OK" crap in front of the API key string, and things send as expected.  Now, what's going on that I can't grab the contact phone number? 

Edited by gvantass
Link to comment
  • 3 weeks later...

Thanks for this workflow!


I had some trouble with it: When I pasted my API key into the window from "dial setup", it got registered as "Button returned: OK, apikey". I had to manually edit the api_key file to remove it. Do you think something changed in recent upgrades to Alfred or Mavericks? I'm on Alfred 2.2 and OS 10.9.2

Link to comment
  • 3 weeks later...

Hi folks, I've updated this workflow, which should hopefully address some of the problems people have been having. In particular, it seems the Applescript dialog was causing inconsistent results between different versions of OS X. So I've got rid of that completely and now you just enter your API key directly into Alfred.


Type dial help into Alfred for full instructions.


(See first post for download link, or check Packal.)



Link to comment

Hi Carlos,


I downloaded yesterday. Setting up my APIkey and Alfred returns a confirmation that API key has been stored, but when I try to do "dial nnnnnnn" I get a notification to set up my API key.

Hi there. This could be a file permissions problem. Can you check if the following file exists:

/Users/YOUR_USERNAME/Library/Application Support/Alfred 2/Workflow Data/carlosnz.dialler/api_key

And if so, is your API key stored in it?




Link to comment



Thanks for responding. That folder (carlosnz.dialler) does not exist in the location. Other workflow settings are there, including for your timezone workflow that was installed the same day that I tried to set up the dialler.

That's odd. :huh:  Can you create that folder manually "carlosnz.dialler", then run the API setup again ie. ":dialsetup YOUR_API_KEY"?



Link to comment

Thanks Carlos. Manually creating the folder then running setup worked.

Oops. My fault. :wub:  It would appear that the workflow wasn't creating the folder if it wasn't already present. I've just pushed out a fixed version now. (Download link in first post).


Sorry, and thanks for reporting it.




Link to comment
  • 2 years later...

Since Upgrading to Alfred 3 the workflow is not working anymore.


I have re-entered my prowl api-key, but still get the result when dialing a number or a contact:


"You need to enter your API key first:

:dialsetup <YOUR_API_KEY>"


Who else has upgraded to Alfred 3 and experience the same issue?

Any suggestion how to fix it?

Link to comment
  • 3 months later...
16 hours ago, erikcoolen said:

Hi Carlos, any chance of getting this to work on Alfred v3?

Hey, I haven't done anything with this workflow in a long time as you can make calls directly from OS X these days. So no plans to revisit it at this point. However, it's probably not too complicated to tweak it a bit to work with A3 if you really wanted to.



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...