Jump to content

Recommended Posts

Hi,

 

I just whipped up this small application inside of Alfred. It allows you to have multiple projects that you keep your times for. I am planning more for this in the future, but it is very usable as it is. Let me know what you think! You can download this and my other workflows here:

 

https://github.com/raguay/MyAlfred

 

I have more documentation and in the future some tutorials at my web site: http://customct.com

 

All of the workflows now incorporate AlleyOop and can be updated using that workflow. Therefore, if you have already installed these workflows, please install the current version so that future updates will be easier.

 

Latest version: 1.93  06/20/2013

Edited by raguay.customct

Share this post


Link to post

I just updated the version on Git Hub to move all data files to the recommended location in the documents. Now, there is not data files inside the actual workflow. Let me know if there is anything you would like to see in this. I am working on a gui for it as well.

Share this post


Link to post

Hi,

 

Thanks for sharing this. It is very helpful.

 

I have some warning messages that prevent me to see the outputs:

 

 

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in Command line code on line 9
 
Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in Command line code on line 9
00:03:23
 
Any idea how to fix this.
 
Cheers

Share this post


Link to post

Hi,

 

I just pushed a fix for the error reporting issue and added the command "worktime" for displaying all the projects times for one day. You can use "today" for today and "yesterday" for yesterday.

 

Let me know if you find anything else.

Share this post


Link to post

Hi,

 

Thanks for sharing this. It is very helpful.

 

I have some warning messages that prevent me to see the outputs:

 

 

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in Command line code on line 9
 
Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in Command line code on line 9
00:03:23
 
Any idea how to fix this.
 
Cheers

 

Redownload and install the lastest version. It should fix that problem. If not, please let me know.

Share this post


Link to post

I just changed the original post to reflect the new versions of all of my workflows. They are all AlleyOop compatible now. I also fixed a few bugs in the AlfredTimeKeeper workflow. 

Share this post


Link to post

Hi! Thank you for your efforts!

I just added your workflow to my daily routine and it's way more convenient than other programs I used before!

 

However, I've two smaller issues...

The first one is similar to vdesabou's - I receive following 'error message' after setting a project:

 

"Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in Command line code on line 11"
 
Second issue is:
vmonth shows me the correct time spent for a certain project.
vweek only shows 00:00:00.
 
Any ideas? 
 
Kind regards and thank you in advance, Christian

Share this post


Link to post
Guest

Thank you for this awesome workflow!

 

I have replaced your Icon in my copy, because i do not like Icons with non-transparent backgrounds  :rolleyes:

 

HourGlas.png

 

You can use it if you like for your Workflow. I made it by myself and "release" it without any copyright...  ;)

Share this post


Link to post

Updated the functionality of this workflow and added AlleyOOP compatibility. The 'vweek' command now completely works (I believe for sure this time). Could everyone test it and let me know what you find out? Thanks! Working on the ability to edit the time logs graphically.

Share this post


Link to post

I just did an update to replace the PHP script filters with executables written in go. As such, it is now larger but faster. I compiled them on an amd64 Mac OSX 10.8.4 system. Please try it out and see how it runs on your system. I am still fairly new to the go language and I am not sure if it requires libraries to be loaded or not. I believe not.

Share this post


Link to post

Hi, just upgraded the goAlfred library and recompiled this workflow. The latest beta of Alfred 2 showed a bug in my library. It is all fixed now.

 

Therefore, if you installed version 1.5, please upgrade before you upgrade your Alfred 2 installation.

 

Thanks.

Share this post


Link to post

Hi, just pushed the change to TimeKeeper to conditionally create the project list for setting the current project based on the string given by the user. Also, it should not just dump into default search when the user has no output from the letters given in the search. Try it out and let me know if anyone has any problems.

Share this post


Link to post

Hi, just fixed a small bug in the base goAlfred library. If the conditional adding of a result list ends up not adding anything, before the default message would be accepted as a project. It now will not and it will not fall through to default search either. Test it out and let me know if you see any problems. 

Share this post


Link to post

This workflow looks promising. However, after installing it, I can't seem to add a first project. An error occurs when using ATK:addproject projectname. I get a growl notification saying "Could not open the projects file: /Users/myuser/Library/Application Support/Alfr..." and then unfortunately the actual filename is cutoff due to its length. When drilling into the folder  "/Users/myuser/Library/Application Support/Alfred 2/Workflow Data/com.customct.AlfredTimeKeeper/" I find that it is empty. Can you help?

Share this post


Link to post

Hi, Sounds like it is not creating the file like it should. I have it for creating the file if it is not there (which only happens the first time ran). I will look at it and send an update. Sorry about that.

Share this post


Link to post

This workflow looks promising. However, after installing it, I can't seem to add a first project. An error occurs when using ATK:addproject projectname. I get a growl notification saying "Could not open the projects file: /Users/myuser/Library/Application Support/Alfr..." and then unfortunately the actual filename is cutoff due to its length. When drilling into the folder  "/Users/myuser/Library/Application Support/Alfred 2/Workflow Data/com.customct.AlfredTimeKeeper/" I find that it is empty. Can you help?

 

Hi,

 

Found the bug. I forgot the creation flag. The goAlfred program for that functionality now works. Please give it a try and let me know if it helps. Thanks for letting me know.

Share this post


Link to post

Thank you for responding. I can now enter a project using addproject, and the new projects appears in the projects.txt file. However, when I choose to use that project using the ATK:project command, while the added project appears in the list, I get the error "Can [sic] not read the projects file." 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...