Jump to content

Calendar Workflow


Recommended Posts

  • 1 year later...

Is anybody having alignment problems with the calendar's columns (see below)?

 

595e89091bb8a_ScreenShot2017-07-06at2_49_17PM.jpg.e90f31834f2ed2dbc0432fde10b1397d.jpg

 

I tried adjusting the width in the configuration file and redownloading the newest version (to make sure everything is up to date), but nothing appears to be working.

 

Any advice for fixing it? Thanks!!

Link to comment
  • 5 months later...
  • 3 years later...

Hi Vero,

 

I worked with Alfred support and identified the issue. I don't heavily use this workflow anymore so I didn't troubleshoot it further. It's related to an issue with Python which causes Python to crash when this workflow is executed or the calendar app is launched, and only happens on Big Sur (did not happen on previous OS). 

 

image.thumb.png.87192f3e7eb5bd2e5e635a3e03d5fcbb.png

Link to comment
  • 2 weeks later...

Welcome to the forums, @cleobis.

 

23 hours ago, cleobis said:

I believe I have resolved the crash. Formatting is a bit wonky and still needs to be fixed.

 

Unfortunately, the formatting is what makes the Workflow. The calendaring itself is unimpressive—run cal in a Terminal and you’ll see what I mean; parsing that is dead simple and can be done in 5 minutes with way less code (speaking from experience). What made this Workflow interesting was the correct theme-independent formatting.

 

What’s needed is to fix the dependency, not disable it.

Edited by vitor
Link to comment
  • 5 months later...
  • 6 months later...

@vitor  likely yes but it will be a while. 

 

I haven’t yet updated to macOS 12.3 so I am not yet running into the issue of python 2 being removed. Once I gupgrade, I will likely fix the plug-in. It will be a while as I don’t have much time to spend on the side project. 
 

The plug-in depends on the workflow library which I don’t think has been updated to python 3. For the system calls, they can be moved into an executable. I need to think about if the python runtime should be bundled with the plug-in or require users to install python 3. 

Link to comment
1 minute ago, cleobis said:

likely yes but it will be a while.

 

Thumbs up! I like this one so looking forward to seeing it continue. I’m not on 12.3 yet either, but figured it was a good idea to check. Thank you for the fast answer.

 

3 minutes ago, cleobis said:

I need to think about if the python runtime should be bundled with the plug-in or require users to install python 3.

 

I recommend the latter. For a while now there have been several Workflows requiring users to install Python 3 via Homebrew and it doesn’t seem like it has been a huge deal.

 

Plus, you’d have to package a Python runtime with double the size (Intel and Apple Silicon). That would take some work and it would make the Workflow huge.

 

Python 3 is one of the least cumbersome dependencies to fix right now because once you call python3, if the user doesn’t have it macOS itself will show a GUI dialog asking the user to install the developer tools. In literally 2 clicks (and waiting for a progress bar to fill) it’s done.


Do it like so and it will use Homebrew’s Python 3 if the user has it installed:

 

export PATH="/opt/homebrew/bin:/usr/local/bin:${PATH}"
python3 main.py "{query}"

 

As long as you target the script to work on Python 3.8.9 or under (the one that ships with the developer tools in Monterey), you should be good either way.

Link to comment
  • 2 months later...

I think I have it working now. The delay was due to the difficulty of either bundling the pyobjc dependency or requiring users to install it. In the end, I avoided the problem by porting the affected code to AppleScript. An updated version is available at the link below. I will remove pre-release marking once I hear that it is working from a few users.

 

https://github.com/cleobis/alfred-cal/releases/tag/v1.6.0

Link to comment
12 hours ago, cleobis said:

I will remove pre-release marking once I hear that it is working from a few users.

 

Working fine for me. I encourage others to add a like to @cleobis’s comment above if it works for them too, because it will be an easy way to keep track.

Link to comment
  • 1 month later...
Posted (edited)

@ravage123, Can you please provide more information on the failure? In what way does it not work?

 

Open the workflow in Alfred preferences. Click the bug symbol in the top right corner to display the workflow debug messages. Run the workflow. Copy the debug messages and post them to the forum. 
image.thumb.png.ee53a3d36b02d66186f49108ae77b71d.png

Edited by cleobis
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...