Jump to content

clipboard merge - causes fast append when not wanted


drwatson
 Share

Recommended Posts

  • What you were doing when the issue happened

I was copying with command+c

  • Whether you were able to replicate it

Not on demand, but it happens frequently

  • Include any screenshots that might help us

sorry

  • Include the version and build number from Alfred's General preferences (bottom left)

2.7.2

 

This bug has been present for quite some time, but because I disabled merging (because of the bug) I forgot about it.  It occurs frequently when I hit command+c that the notification of fast append is happening even though I only hit command+c once  (no double-tap). I love this feature and I used it a lot before this started happening.

 

 

  •  

Link to comment
Share on other sites

  • 1 month later...

Hi Andrew, i'm not running anything else :(

 

Granted, I'm on El Capitan now when this is happening. 

 

I've been keeping an eye out for this behaviour on El Capitan and haven't managed to reproduce it. A few questions...

 

Are you still experiencing the issue now that 10.11 is GA?

Are you using an Apple brand Keyboard?

Is it only in certain types of software (e.g. Parallels or Java)

 

Cheers,

Andrew

Link to comment
Share on other sites

Yes, it's happened and is happening in iTerm 2. Quite frequently so, must be something with that

 

Ah, iTerm must be configured to "Copy on Select", which essentially means you are selecting text, this is being put into the OS X clipboard, then you are pressing cmd+c so it's being put into the OS X clipboard again which is why Alfred is triggering a merge.

 

You could either disable "Copy on Select" in iTerm, or not press cmd+c after selecting text in iTerm as it's already copied as soon as you select.

 

Let me know how you get on! :)

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 6 years later...

This is still an issue, I was having the same problem with iTerm. Any chance of coding an alert/warning to avoid this frustration? Or perhaps notice that it's iTerm and run a self test? For what it's worth, it happens only half the time and I can't tell when it'll trigger.

 

I'm sure I'm not the only person that this was making nuts.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...