Jump to content

iTerm no longer a Terminal Application


amityweb

Recommended Posts

Both iMac and Macbook have this, must have been a recent update (after which Alfred did not work I had to manually restart it)...

 

Previously I chose iTerm to run terminal commands when I used the prefix >

 

But iTerm is no longer in the applications list. The Custom command used for Terminal which its now using does not work for iTerm when I change "Terminal" to "iTerm"

 

So I cant get iTerm to be the default terminal application following the recent update

 

Thanks

Link to comment

Are we overcomplicating things? It worked fine for me before, but now I have to get involved in custom scripts.

 

This decision was made as iTerm's AppleScript was evolving over time (and there are now two different versions with two different integrations). By separating it, a working integration (without quirks such as the double open tab) can be released without Alfred's core being updated too.

 

Cheers,

andrew

Link to comment

I just want the old behavior back since it worked great for me.  I ended up with this script:

on alfred_script(q)
	tell application ":Applications:MacPorts:iTerm2.app"
		activate
		tell the first terminal
			set mysession to (launch session "Default Session")
			tell mysession to write text q
		end tell
	end tell
end alfred_script

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...