Jump to content

1Password integration misses many entries in bookmarks-default.json


crisb
 Share

Recommended Posts

I haven't counted them up, but the list of 1Password 1-click passwords in Alfred prefs -> Features -> 1Password is missing many entries in my bookmarks-default.json.

 

Alfred does find the file (set to 'discover automatically' in the Advanced dialogue), and a subset of the bookmarks. But some are missing (I've looked at bookmarks-default.json in a text editor and can see many bookmarks there that are not found by Alfred).

 

There's nothing obvious in bookmarks-default.json to distinguish the bookmarks Alfred does find from the missing ones. 

Link to comment
Share on other sites

I haven't counted them up, but the list of 1Password 1-click passwords in Alfred prefs -> Features -> 1Password is missing many entries in my bookmarks-default.json.

 

Alfred does find the file (set to 'discover automatically' in the Advanced dialogue), and a subset of the bookmarks. But some are missing (I've looked at bookmarks-default.json in a text editor and can see many bookmarks there that are not found by Alfred).

 

There's nothing obvious in bookmarks-default.json to distinguish the bookmarks Alfred does find from the missing ones. 

 

Alfred only treats valid URLs as valid bookmarks. If an entry in 1Password is missing either http or https in the URL, Alfred doesn't include these so as not to make any assumptions... so the missing items may just be missing http or https in their URLs in 1Password.

 

Let me know! :)

 

Cheers,

Andrew

Link to comment
Share on other sites

@

 

Alfred only treats valid URLs as valid bookmarks. If an entry in 1Password is missing either http or https in the URL, Alfred doesn't include these so as not to make any assumptions... so the missing items may just be missing http or https in their URLs in 1Password.

 

Let me know! :)

 

Cheers,

Andrew

 

Hi Andrew -- thanks for the reply! That's not it in this case. Here's an example of an entry in bookmarks-default.json but not showing up in Alfred:

["[hash]","Udacity","https:\/\/udacity.com"]

That's typical of the missing bookmarks. They don't seem to differ in any obvious way from the ones that are showing up, though I confess I haven't spent the time to look through thoroughly yet. I've been using Alfred for ages, but for some reason never got around to using the 1Password integration, so have only just discovered this issue.

Cheers,

Cris.

Link to comment
Share on other sites

Got it! I manually added the path to bookmarks-default.json, and Alfred picked up all the logins.

 

This solves my problem, but it presumably means Alfred was automatically looking in the wrong spot? Anyway, I'm happy now.

 

Do you have more than one version of 1Password installed? E.g. beta and app store?

Link to comment
Share on other sites

Do you have more than one version of 1Password installed? E.g. beta and app store?

 

 

Ah, that's the issue. I only use the beta these days but have had the app store version in the past. And sure enough there's a stale bookmarks-default.json in ~/Library/Containers/(etc).

 

Thanks again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...