Jump to content

New bug with OSX Spaces, Alfred and Dash


Recommended Posts

There was a change in the latest release of Alfred (v2.7.2 (407)) which has broken one of my use-cases for it.

 

I use Dash and their Alfred integration. I have my text editor in a different OSX Space and I'm normally in my text editor when I want to use dash. If I trigger the dash workflow from a secondary space (e.g. by selecting "javascript" to look up a javascript method) then my screen slides back into the first space (I think as Dash is opened) but the Alfred popup is still on my secondary space so I need to switch back to that in order to complete my lookup.

 

If Dash is already open then the problem doesn't happen so it's due to how Dash is opened by Alfred. However, on the previous version of Alfred this workflow worked fine (I can't remember for sure but I think that it switched back to the primary space but Alfred also switched to this space). I'm not sure if this is something that Dash can fix in their workflow or if it is something that needs to be fixed in Alfred.

 

Let me know if you need further information. This is on Yosemite 10.10.5 (14F27) in case that changes anything but like I say it started happening when I updated to the latest Alfred yesterday.

Link to post
Share on other sites

There was a change in the latest release of Alfred (v2.7.2 (407)) which has broken one of my use-cases for it.

 

If you update to the 2.7.3 pre-release (in Alfred's update prefs), you can now set a compatibility mode which will make Alfred focus like 2.7.1. Having said that, it might be worth mentioning this to Dash as there may be something he can do about this. If at all possible, you'd want to stick with the new activationless focusing in 2.7.2 as this makes Alfred's experience throughout OS X much smoother.

Link to post
Share on other sites

The only way I'm able to replicate this is if I right click on the Dash icon in the Dock and go to "Options > Assign to... This Desktop" and after that the desktop/space is changed whenever Dash launches, which causes Alfred to be left behind on the old space. Without setting that option I'm not able to replicate it.


 


@vitch can you check if you have this option enabled? If yes and this is the behaviour you want, there's nothing I can do on my end to get the Alfred window to relocate to the new desktop/space after it's changed by the Dash launch. The only thing I can do is to make sure Dash launches on your current space/desktop, which seems to work fine as far as I can tell, as long as it's not assigned to a certain space. As far as I'm aware, there's no way to prevent an app from changing the active space at launch when that option is enabled.


 


@Andrew Maybe you can watch for space change notifications and move the Alfred window when that happens?


Link to post
Share on other sites

 

@Andrew Maybe you can watch for space change notifications and move the Alfred window when that happens?

 

 

I can definitely look into this...

 

@vitch - can you also check if Alfred is set to show on the "active screen" in the Appearance > Options. Also, did the compatibility mode work out for you?

Link to post
Share on other sites

Hi,

 

Thanks for the replies. My answers below:

 

 

The only way I'm able to replicate this is if I right click on the Dash icon in the Dock and go to "Options > Assign to... This Desktop" and after that the desktop/space is changed whenever Dash launches, which causes Alfred to be left behind on the old space. Without setting that option I'm not able to replicate it.

 

 

 

I don't have that option. This is all I have on that right click menu:

 

https://drive.google.com/file/d/0BzNk1K41aEPGWjllTnF5TjdJb1k/view?usp=sharing

 

 

 

I can definitely look into this...

 

@vitch - can you also check if Alfred is set to show on the "active screen" in the Appearance > Options. Also, did the compatibility mode work out for you?

 

Alfred was set to "default screen" but I changed it to "active screen" and the behaviour was the same.

 

I also just tried updating to the 2.7.3 pre-release but I can't see where to turn compatibility mode on.

 

I also uploaded a video showing the bug in action:

https://drive.google.com/file/d/0BzNk1K41aEPGb1Vfb3JrRTQyT0E/view?usp=sharing

 

Thanks!

Link to post
Share on other sites

 

I also just tried updating to the 2.7.3 pre-release but I can't see where to turn compatibility mode on.

 

 

Compatibility mode is in Alfred's Appearance > Options in the bottom left "Focusing". This will make Alfred operate more like he did before 2.7.2.

 

Alfred shouldn't be changing spaces by itself, the window is closed each time so when re-shown, it should show on the currently active display. Even this mission control option should (and in my case doesn't) affect where Alfred shows, even with Alfred's preferences open on the other space.

 

active%20app.png

So I'm not really sure why the spaces are changing when you show Alfred hmm.

Link to post
Share on other sites

Switching to compatibility mode does restore the previous working behaviour.

 

Once I trigger Dash from Alfred I still switch space to the default one (where dash runs) but Alfred comes with me to that space:

 

https://drive.google.com/file/d/0BzNk1K41aEPGajJNVzhaelRmMGs/view?usp=sharing

 

Changing the Mission Control setting doesn't fix the problem in Alfred "Standard mode" but does generally break my expected behaviour of the OS (e.g. switching to Sublime won't switch to that space any more).

 

 

 

Alfred shouldn't be changing spaces by itself, the window is closed each time so when re-shown, it should show on the currently active display. 

 

This is true (as you can see in the videos I have uploaded). The problem seems to be that when Dash gets opened (so that it can provide the search results to Alfred) it pulls the focus to the default space. Now that Alfred doesn't follow the active space by default this means you lose Alfred.

 

The ideal solution would be Dash being able to open in the background and provide search results without pulling to the default space. This is the behaviour if Dash is already open when you use Alfred to search it...

Link to post
Share on other sites

@vitch It's not normal not to have the "Assign to..." option in the dock. Do this:

 

1. Open at least 2 spaces

2. In Dash's Preferences > General make sure "Dismiss main window when I activate a different app" is disabled

3. Make sure Dash's main window is open and right click the dock icon again

 

I'm not able to view the video you made. I keep getting this: "The server encountered a temporary error and could not complete your request.". Can you upload it somewhere else?

Link to post
Share on other sites

Thanks for the reply :)

 

I've uploaded the videos to dropbox:

https://www.dropbox.com/sh/ryper72nbe70gez/AACp8B3VlpsSop_5ZGTTANd-a?dl=0

 

I can confirm that "Dismiss main window when I activate a different app" is disabled

 

I managed to get the "Assign to..." option in the dock. To do this I had to create an extra space via Mission Control. The "spaces" that I have aren't spaces with desktops, they are the full screen versions of iTerm2 and Sublime Text (you can see in the video).

 

Does that help to understand the problem?

Link to post
Share on other sites

Fullscreen apps are different from spaces.

 

There's no way for me to prevent Dash from changing the space from a fullscreen app when it's launched. You could try setting Dash to the HUD window style mode or set it to Assign to... > All, but I'm not sure that would work.

 

My recommendation would be to keep Dash open :)

Link to post
Share on other sites

You could try setting Dash to the HUD window style mode or set it to Assign to... > All, but I'm not sure that would work.

 

That fixed it! It seems to work great alongside any of Alfred's modes. Dash obviously closes when it loses focus in this mode but I think it works better for me than the other way around.

 

Thanks both for your help getting to the bottom of this...

Link to post
Share on other sites
×
×
  • Create New...