Jump to content

Clipboard no longer works with RubyMine


duhryguy
 Share

Recommended Posts

The latest update to Alfred broke the Clipboard History feature when using it from within the RubyMine application. I'm not sure if this is an issue with RubyMine or Alfred and I don't blame you want to file as a "won't fix." But I haven't updated RubyMine in a awhile, and as soon as I updated Alfred yesterday it stopped working. I can open the clip board history (mapped to CMD+V+SHFT) but when I select an item to paste, it only pastes the last copied item. This happens every time, consistently.

 

If this can't be fixed it, can I download and use an older version? Thanks.

  1. What you were doing when the issue happened
    Using RubyMine version 6.3
  2. Whether you were able to replicate it a second time by performing the same action
    Yes
  3. Include any screenshots that might help us
    Nothing to show really, just only pastes the last item, ignoring older items in the clipboard
  4. Include the Alfred version & build number you are using
    v2.8 (414)
  5. Include your OS X version
    Yosemite 10.10.3 (14D136)
Link to comment
Share on other sites

 

The latest update to Alfred broke the Clipboard History feature when using it from within the RubyMine application. I'm not sure if this is an issue with RubyMine or Alfred and I don't blame you want to file as a "won't fix." But I haven't updated RubyMine in a awhile, and as soon as I updated Alfred yesterday it stopped working. I can open the clip board history (mapped to CMD+V+SHFT) but when I select an item to paste, it only pastes the last copied item. This happens every time, consistently.

 

If this can't be fixed it, can I download and use an older version? Thanks.

  1. What you were doing when the issue happened

    Using RubyMine version 6.3

  2. Whether you were able to replicate it a second time by performing the same action

    Yes

  3. Include any screenshots that might help us

    Nothing to show really, just only pastes the last item, ignoring older items in the clipboard

  4. Include the Alfred version & build number you are using

    v2.8 (414)

  5. Include your OS X version

    Yosemite 10.10.3 (14D136)

 

 

In Alfred 2.8's Appearance > Options, select the focus to "Compatibility Mode".

 

Java caches the clipboard if the focus doesn't change. By setting Alfred to Compatibility Mode, he will take focus from OS X like he did pre-2.7.2 and should work with Java.

 

Cheers,

Andrew

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...