Jump to content
joshka

Freezes when program does not start correctly

Recommended Posts

Bitwig occasionally doesn't start properly. Running it from Alfred (v2.8 414) freezes Alfred (window / tray icon are unresponsive)

OSX 10.11.0

Repro - often. I'm not sure why Bitwig (1.3) fails to run, but it's likely a bug / something to do with 10.11.0.

Screenshot: https://www.dropbox.com/s/mfk50bupywd004h/Screenshot%202015-11-12%2023.57.29.png?dl=0

Edited by joshka

Share this post


Link to post

Bitwig occasionally doesn't start properly. Running it from Alfred (v2.8 414) freezes Alfred (window / tray icon are unresponsive)

OSX 10.11.0

Repro - often. I'm not sure why Bitwig (1.3) fails to run, but it's likely a bug / something to do with 10.11.0.

Screenshot: https://www.dropbox.com/s/mfk50bupywd004h/Screenshot%202015-11-12%2023.57.29.png?dl=0

 

I suspect this is an issue with El Capitan / Bitwig / Java...

 

http://answers.bitwig.com/questions/4659/bitwig-12-doesnt-start-on-el-captain-after-you-closed-it

 

I have had the dock also freeze when trying to launch bitwig for the second time.

 

I'm moving this to "noted" but I'm sure it will get fixed indirectly with an update of OS X / Bitwig.

 

Cheers,

Andrew

Share this post


Link to post

Thanks Andrew,

 

I figured as much on the bitwig side of things, but I think there's possibly some prevention that could be added to Alfred to ensure that I can still use my system after bitwig doesn't start (yep Alfred is that indispensable that I can't picture myself without it ;))

 

From an Alfred perspective, it seems odd that it would lock up due to a poorly performing external app. Perhaps spawning a new thread / process to perform the actual execution would solve this issue. Comparatively spotlight continues to work in this instance

Share this post


Link to post

Thanks Andrew,

 

I figured as much on the bitwig side of things, but I think there's possibly some prevention that could be added to Alfred to ensure that I can still use my system after bitwig doesn't start (yep Alfred is that indispensable that I can't picture myself without it ;))

 

From an Alfred perspective, it seems odd that it would lock up due to a poorly performing external app. Perhaps spawning a new thread / process to perform the actual execution would solve this issue. Comparatively spotlight continues to work in this instance

 

While there probably is something I could cobble together to defend against this scenario, it may have performance implications for the rest of Alfred to account for a (hopefully temporary) OS X error.

 

A better solution would be to put something like this into a workflow:

https://github.com/jhorology/bitwig-el-capitan-launcher

 

Which is exactly what I've done for you here... :D

https://dl.dropboxusercontent.com/u/6749767/Alfred/Workflows/Bitwig%20Launcher.alfredworkflow

 

Drag Bitwig Studio.app into OS X's spotlight privacy preferences and type 'reload' into Alfred to prevent the original app from showing up.

 

It's worth noting that launching directly stops the splash screen from showing, which is essentially what I think is causing the issue in El Capitan.

 

Hope this helps!

 

Cheers,

Andrew

Share this post


Link to post
×
×
  • Create New...