Jump to content
Sign in to follow this  
thedarkbrownman

Alfred No Longer Finding Folders

Recommended Posts

Hi,

I've been using Alfred the past month and I've become a huge fan. Yesterday I purchased the PowerPack, and since enabling it, I've run into one issue.

Namely, before activating the PowerPack, Alfred used to search for my folders whenever I would type in a folder name. It no longer does that. 

(For example, I have a couple of folders on my computer called 'Sharon'; when I now type 'Sharon' into Alfred's search bar, only a contact matching Sharon appears; the folders named 'Sharon' no longer show up in the Alfred results). This is the case with nearly any folder search I complete (none of my folders are being searched!) In fact, I can't even search for applications anymore either (if I type in 'Evernote', only a Google search comes up for Evernote).

I have no idea why this is occurring. Under my Alfred settings, and in the 'Features' tab, under 'Default Results' I have 'Folders' checked (I also have Applications checked as well). Additionally, the folders I am searching for are under the 'Search Scope' of a folder pathway I've defined. 

Any help on this issue would be greatly appreciated. Being unable to search for folders has been hindering my productivity in a major way! Life is much easier when Alfred can search my folders too.

Cheers!

Share this post


Link to post

Hi,

I've been using Alfred the past month and I've become a huge fan. Yesterday I purchased the PowerPack, and since enabling it, I've run into one issue.

 

It'll be a coincidence if you're struggling to get to your workflows after activating the Powerpack, as activating doesn't change anything to the underlying index Alfred uses to search your folders.

 

You seem to have already checked the essential first steps; Ensuring that folders are included in your default results, and checking that they're within your search scope. Reset your search scope to defaults if you're unsure whether they're correctly included.

 

Next, launch the preferences to the Advanced tab and click "Rebuild OS X metadata", follow the steps including deleting /.Spotlight-V100 and enter your password. You'll then either see an error message relating to your index, if anything's not right, or you'll get a notice that your Mac's metadata is being indexed. Take a look at Step 4 here for details: https://www.alfredapp.com/help/troubleshooting/indexing/

 

Once you've let your Mac rebuild the metadata, search once again and let me know how you get on :)

 

Cheers,

Vero

Share this post


Link to post

Hi Vero,

Thanks for the quick response. So I also tried rebuilding the OS X metadata. I, in fact, did receive an error message in the terminal that reads as follows:
 

2015-11-30 17:34:51.331 mdutil[7150:3277629] Metadata.framework [Error]: mdsCopyStorePaths failed: (268435459) (ipc/send) invalid destination port

Spotlight server is disabled.
 

In a few moments, OS X will start rebuilding your metadata index.

 

Press any key to close Terminal and continue...

 

After completing this task, the terminal reads "[Process completed]". Nevertheless, after waiting, the issue has still not yet been resolved.

Any other suggestions? Thank you for taking the time to read my issue and to respond.

Thanks!

Share this post


Link to post

Hi Vero,

Thanks for the quick response. So I also tried rebuilding the OS X metadata. I, in fact, did receive an error message in the terminal that reads as follows:

 

2015-11-30 17:34:51.331 mdutil[7150:3277629] Metadata.framework [Error]: mdsCopyStorePaths failed: (268435459) (ipc/send) invalid destination port

Spotlight server is disabled.

 

If Spotlight is disabled on your Mac, OS X itself, as well as Alfred and many other apps who rely on that metadata, won't be functioning properly. It's just more often obvious in Alfred, as you use it primarily for search :)

 

If you follow the steps recommended in the comments of this post and post these two lines, one after the other, into Terminal, you'll be able to reset your indexing, which should allow you to reindex normally.
 
Disable indexing:
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
 
Enable indexing:

 

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
 
Let me know how you get on :)
 
Cheers,
Vero

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...