capripot

'Active screen' bug

7 posts in this topic

In apperance > Options > Show Alfred on

with OS X El Capitan 10.11.1 with Alfred 2.8.1

when I select active screen, it doesnt work properly with full screen apps (whichever).

 

Any plan to fix that?

Share this post


Link to post

Could you get a screenshot or video (in QuickTime Player you can File → New Screen Recording) of the behaviour? “Doesn’t work properly” doesn’t tell us much and I cannot reproduce. It’s working fine for me.

Share this post


Link to post

Here is the video:

 

This screen is the attached screen connected with DisplayPort to a MacBook Pro 13" early 2015,

defined as second screen in System Preferences > Display > Arrangment

When the mouse stops, I hit the combinaison of keys to show Alfred, but it shows on the main screen even if the active window is the fullscreen one under the mouse on second screen.

It happens with any application in fullscreen, here I tried with iTerm and iTunes

 

Most of the time, I use the keyboard to switch from one app to the other, so the mouse stays on main screen but active windows is on second screen, attained with cmd+tab, thats why I can't use "mouse" option instead.

Edited by capripot

Share this post


Link to post

Unfortunately, this is a bug in OS X's NSScreen API... I've attached a screenshot of the API call which Alfred uses, which doesn't return the correct screen when using full screen apps.

 

Apple doesn't have a good track record of fixing bugs like this between major releases, so I guess it's fingers crossed in this case!

 

Cheers,

Andrew

 

NSScreen%20mainScreen.png

Share this post


Link to post

Ugh Apple...

 

Thank you Andrew for your answer! I was thinking it was something like that.

Edited by capripot

Share this post


Link to post

I was wondering, since Spotlight get it right,

 

maybe there is another way to get the active screen right? What do you think?

Share this post


Link to post

I was wondering, since Spotlight get it right,

 

maybe there is another way to get the active screen right? What do you think?

 

 

It looks like Spotlight just shows on the screen the mouse pointer is on - Alfred also has this mode: "Show Alfred on mouse screen" in the Appearance > Options.

 

Cheers,

Andrew

Share this post


Link to post