Jump to content
JLoun

Force Keyboard effects other windows

Recommended Posts

No sure if it's Alfred's problem, but at least it's not happening with Spotlight. 

 

Here's my scenario:

 

1. Choose "ABC"(English) keyboard as the "Force Keyboard" in Alfred.

2. Checked "Automatically switch to a document's input method" in OS X's Keyboard preference.

3. Use a Chinese IME in TextEdit.

 

The problem is, whenever I use opt+space to activate Alfred, then switch back to the previous TextEdit window to resume typing, the IME got switched to "ABC", hence Alfred's Force Keyboard. I think the problem appeared in recent versions, although not sure which one. 

 

I'm using Mac OS 10.11.2 with Alfred 2.8.1. 

 

 

Share this post


Link to post

No sure if it's Alfred's problem, but at least it's not happening with Spotlight. 

 

Here's my scenario:

 

1. Choose "ABC"(English) keyboard as the "Force Keyboard" in Alfred.

2. Checked "Automatically switch to a document's input method" in OS X's Keyboard preference.

3. Use a Chinese IME in TextEdit.

 

The problem is, whenever I use opt+space to activate Alfred, then switch back to the previous TextEdit window to resume typing, the IME got switched to "ABC", hence Alfred's Force Keyboard. I think the problem appeared in recent versions, although not sure which one. 

 

I'm using Mac OS 10.11.2 with Alfred 2.8.1. 

 

Take a look at this page for info on how to tell Alfred which language you want him to use:

https://www.alfredapp.com/help/troubleshooting/keyboard-language/

 

(Note: The page hasn't been formally updated for 10.11 El Capitan so don't hesitate to ask if you have any questions. I'll be updating that page shortly :) )

Share this post


Link to post

Take a look at this page for info on how to tell Alfred which language you want him to use:

https://www.alfredapp.com/help/troubleshooting/keyboard-language/

 

(Note: The page hasn't been formally updated for 10.11 El Capitan so don't hesitate to ask if you have any questions. I'll be updating that page shortly :) )

 

Thanks for your reply, but I'm don't think the page solved my problem. For one thing, I NEED the "Automatically switch to a document's input method" box to be checked. 

 

Let me further describe the way I use Alfred: 

 

I have three windows with different language settings, 1) TextEdit, always in Chinese; 2)Alfred, always in English; 3) Dictionary.app, always in English. (I must reiterate that, this is the way it used to be, and I started to have this problem only with the recent few versions of Alfred.)

 

While typing Chinese in TextEdit, I might want to Google something, so I use opt+space to activated Alfred, type in English keyword, then ctrl+enter to let Alfred send me to Chrome. 

 

Now, I understand that if I've let the "Automatically switch to a document's input method" box unchecked, whenever I switch back to TextEdit, the language will still be Chinese. But the problem is, I also want to keep the search box of Dictionary.app in English. Uncheck "Automatically switch to a document's input method" means, I will have to manually switch to English every time I use Dictionary.app. And that's really inconvenient. 

Share this post


Link to post
The problem might be that recent versions of Alfred use a different focus mode.
 
Try changing the Focusing in Alfred Preferences > Appearance > Options to Compatibility Mode.
 

 

That will make Alfred take focus the old-fashioned way.

Share this post


Link to post

 

The problem might be that recent versions of Alfred use a different focus mode.
 
Try changing the Focusing in Alfred Preferences > Appearance > Options to Compatibility Mode.
 

 

That will make Alfred take focus the old-fashioned way.

 

 

That seems to be it, much appreciated! 

Share this post


Link to post
×
×
  • Create New...