Jump to content

Evernote Workflow 9 beta 4 (Alfred 4)


Recommended Posts

I just downloaded this today and it works great! Thanks for all your work on this.

 

Could someone please tell me if this is possible? I'd like to append information to an existing note with this Alfred script. The note is titled Daily Task Log: 2014-10-16 but the date changes the title every day. I'm attaching a screenshot of the formatting of the note but basically I'd just want a timestamp and a short description appended. Here's what a note looks like: http://d.pr/i/16gP9/13Z0wacv

 

Is there a way of modifying one of these scripts to accomplish that?

Link to post
  • Replies 833
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Alfred 4 Read about this workflow below.   This is an update to address the new Alfred 4 data folder (thanks to xilopaint). DOWNLOAD Evernote Workflow 9 beta 4 for Alfred 4  

Evernote workflow 9 beta 3 released with minor code optimizations and updated workflow preferences.   Download Now   If your search (ens keyword) is not returning any results pleas

@All:   Here is a very early version of the workflow that starts to add support to Evernote 6.06+. There are a lot of code lines to review and test so there is a chance that something still needs to

Posted Images

I just downloaded this today and it works great! Thanks for all your work on this.

 

Could someone please tell me if this is possible? I'd like to append information to an existing note with this Alfred script. The note is titled Daily Task Log: 2014-10-16 but the date changes the title every day. I'm attaching a screenshot of the formatting of the note but basically I'd just want a timestamp and a short description appended. Here's what a note looks like: http://d.pr/i/16gP9/13Z0wacv

 

Is there a way of modifying one of these scripts to accomplish that?

 

 

I think it is possible to add current date as a template feature like selection and clipboard. Read about templates here.

 

Do you have PayPal? I want to donate money to you for doing such a good job maintaining this workflow. I use it every day multiple times a day.

 

 

Ditto.

 

Thank you. It is very nice to know the workflow is useful for you and that’s all that matter. :)

Link to post

When I try to use this workflow, it fails as soon as I use the spacebar. Alfred just reverts to a standard search. Here's the debug:

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:98: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:99: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:100: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:101: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:103: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:105: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:106: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:98: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:99: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: Can’t get property list file "/Users/ifly97/Library/Application Support/Alfred 2/Workflow Data/com.sztoltz.evernote/settings.plist" of application "System Events". (-1728)

Link to post

When I try to use this workflow, it fails as soon as I use the spacebar. Alfred just reverts to a standard search. Here's the debug:

 

...

 

1. Delete the workflow from Alfred preferences

2. Download version 8.92 of the workflow from here

3. Install the workflow again

4. Make sure to use Evernote app from evernote.com

5. Make sure to update Alfred

Link to post

Carlos,

 

Thank you so much for this workflow. Saves a lot of time and is key to my productivity workflow. I use the enn feature to create a note from a mail message quite often. When I do so the first 10-15 lines of the note is header info that is not needed, just a plain from and to would be enough.

 

Would it be possible to change the workflow that way? Or is there something I can edit to make the header more concise?

 

Best,

Fokke

Link to post

Carlos,

 

Have problems again, don't really knows what the problem is. The problem is always when typing "enn"

 

Using:

OS X Yosemite 10.10

Evernote from evernote.com 5.6.1

Alfred 2.5

Evernote workflow 8.92

Parallels desktop with Windows 8

 

The problem now is when i type "enn" the search google, search amazon and search wikipedia turns up(loading options take some time). I have deleted and installed and restarted workflow, evernote and alfred, didn't help.

 

After approx 30 minutes and no action done it worked again (don't understand)

 

Is there some cash to empty or what kind of problem could it be? The problem turns up from time to time (see my earlier posts)

Link to post

Carlos,

 

Have problems again, don't really knows what the problem is. The problem is always when typing "enn"

 

Using:

OS X Yosemite 10.10

Evernote from evernote.com 5.6.1

Alfred 2.5

Evernote workflow 8.92

Parallels desktop with Windows 8

 

The problem now is when i type "enn" the search google, search amazon and search wikipedia turns up(loading options take some time). I have deleted and installed and restarted workflow, evernote and alfred, didn't help.

 

After approx 30 minutes and no action done it worked again (don't understand)

 

Is there some cash to empty or what kind of problem could it be? The problem turns up from time to time (see my earlier posts)

 

I had to downgrade to Evernote 5.5.1 because the current version has too many bugs, specially regarding AppleScript.

 

I’ll try to make some tests as soon as possible and I’ll try to make some error handling across enn keyword.

Link to post

Carlos,

 

Thank you so much for this workflow. Saves a lot of time and is key to my productivity workflow. I use the enn feature to create a note from a mail message quite often. When I do so the first 10-15 lines of the note is header info that is not needed, just a plain from and to would be enough.

 

Would it be possible to change the workflow that way? Or is there something I can edit to make the header more concise?

 

Best,

Fokke

 

You can try to edit line 553 of en_addnote.scpt:

set sNote to (paragraph 1 of theHeader & return & paragraph 2 of theHeader & return & paragraph 3 of theHeader & return & paragraph 4 of theHeader & return & return & sNote)

Maybe removing paragraph 1 of theHeader & return &

Link to post

I had to downgrade to Evernote 5.5.1 because the current version has too many bugs, specially regarding AppleScript.

 

I’ll try to make some tests as soon as possible and I’ll try to make some error handling across enn keyword.

 

I also experiencing bugs and not working enn keyword. I thought it was because of Alfred but your suggestion is that it is Evernote. Will downgrade and see what happens.

 

Thnxs.

Fokke

Link to post

Using Evernote 8.9.2 workflow on Yosemite. When I try to enter a new note (ENN type-a-note) I get two popups asking me where Google Chrome.app is.

I don't have and I don't want Chrome on my Mac.

 

Is there a way to get rid of that popup?

 

It should not ask anything.

 

I’ll try to reproduce the issue.

 

[update] Please try version 8.93: download

Edited by Carlos-Sz
Link to post

 

[update] Please try version 8.93: download

 

Hi Carlos,

 

Tried 8.93 but the enn keyword is broken. Probably by Evernote, I use the newest version. Debugging resulted in error message below:

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: Can’t get item 1 of {}. (-1728)

 

If you have a link to the latest stable Evernote version I can revert back to would be great. Couldn't find it on the Evernote site.

 

Fokke

 

[update] Sometimes enn seems to work and sometimes not. Workaround is not typing 'enn' but type 'en' and wait till Alfred will suggest enn as the first option, hit enter and then the flow works.

Edited by kiddokay
Link to post

Hi Carlos,

 

Tried 8.93 but the enn keyword is broken. Probably by Evernote, I use the newest version. Debugging resulted in error message below:

 

[ERROR: alfred.workflow.input.scriptfilter] Code 1: 0:90: execution error: Can’t get item 1 of {}. (-1728)

 

If you have a link to the latest stable Evernote version I can revert back to would be great. Couldn't find it on the Evernote site.

 

Fokke

 

[update] Sometimes enn seems to work and sometimes not. Workaround is not typing 'enn' but type 'en' and wait till Alfred will suggest enn as the first option, hit enter and then the flow works.

 

I could not reproduce the issue, at least not yet.

 

I have downloaded a previous version of Evernote from Uptodown (I could not find anything wrong with the file but since it is not from the official site…).

 

[update] here is a new version that removes some manual menu sorting to let Alfred handle it again (Alfred Preferences>Advanced>Top Result Latching) along with some error handling: download

Edited by Carlos-Sz
Link to post

[update] here is a new version that removes some manual menu sorting to let Alfred handle it again (Alfred Preferences>Advanced>Top Result Latching) along with some error handling: download

 

Carlos,

 

Thanks for all your effort to get us going! I can confirm that 8.94 with Evernote 5.7.0 is working ok here for me.

 

Fokke

Link to post

I'm seeing some odd issues appending to notes using 8.9.3 with Evernote 5.7.0 on Yosemite.  

 

I can add new notes all day long without issue but if I try to append to an existing note I get various errors based on the details

 

If I highlight some text in an email for instance and attempt to append text selection I get the following error:

 

[ERROR: alfred.workflow.action.script] Code 1: 0:194: execution error: Evernote got an error: Operation would exceed monthly upload allowance. (1)
[INFO: alfred.workflow.action.script] Processing output 'alfred.workflow.output.notification' with arg ''
My current monthly usage in Evernote is 72MB out of 4GB. 
 
If I immediately repeat the same operation but create a new note instead of append it works fine.  
 
If I try to append the whole message I get an Error: cannot append message notification.  The log shows:
 
[INFO: alfred.workflow.input.scriptfilter] Processing output 'alfred.workflow.action.script' with arg '/Users/kms/Library/Application Support/Evernote/accounts/Evernote/baryonyx/content/p2116/content.html'
[INFO: alfred.workflow.action.script] Processing output 'alfred.workflow.output.notification' with arg 'Error. Can't append message.

Again, I can create a new note from the message no problem. 

 

If any additional information would be useful, please let me know.  

 

 

 

Link to post

 

I'm seeing some odd issues appending to notes using 8.9.3 with Evernote 5.7.0 on Yosemite.  

 

I can add new notes all day long without issue but if I try to append to an existing note I get various errors based on the details

 

If I highlight some text in an email for instance and attempt to append text selection I get the following error:

 

[ERROR: alfred.workflow.action.script] Code 1: 0:194: execution error: Evernote got an error: Operation would exceed monthly upload allowance. (1)
[INFO: alfred.workflow.action.script] Processing output 'alfred.workflow.output.notification' with arg ''
My current monthly usage in Evernote is 72MB out of 4GB. 
 
If I immediately repeat the same operation but create a new note instead of append it works fine.  
 
If I try to append the whole message I get an Error: cannot append message notification.  The log shows:
 
[INFO: alfred.workflow.input.scriptfilter] Processing output 'alfred.workflow.action.script' with arg '/Users/kms/Library/Application Support/Evernote/accounts/Evernote/baryonyx/content/p2116/content.html'
[INFO: alfred.workflow.action.script] Processing output 'alfred.workflow.output.notification' with arg 'Error. Can't append message.

Again, I can create a new note from the message no problem. 

 

If any additional information would be useful, please let me know.  

 

 

 

 

Unfortunately I had to downgrade Evernote 5.6+ to 5.5.1.

 

Today there is a new version of Evernote but I’m not sure what is fixed.

 

Note that most of the issues are due Evernote app bugs.

 

Anyway, I’ll eventually update Evernote but not for now.

Link to post

I seem to be experiencing an issue where I cannot use the 'open URL' action with this workflow anymore. I'm not too sure why, but it just doesn't do anything when I try the action. Seems like the 'en_open.scpt' could be the issue?

Different workflows which could open in the browser seem to work though, which makes me believe it is something to do with Evernote or the workflow itself.

Evernote: 5.7.2
Workflow 8.9.2

Link to post

I seem to be experiencing an issue where I cannot use the 'open URL' action with this workflow anymore. I'm not too sure why, but it just doesn't do anything when I try the action. Seems like the 'en_open.scpt' could be the issue?

Different workflows which could open in the browser seem to work though, which makes me believe it is something to do with Evernote or the workflow itself.

Evernote: 5.7.2

Workflow 8.9.2

 

Unfortunately Evernote 5.6+ has too many issues with AppleScript.

 

I had to downgrade to Evernote 5.5.x.

 

I’m waiting for a more stable Evernote version. 

Link to post

Hello, I'm a noob here so I'm sorry if this is a stupid question. I'm using evernote 5.7 and your alfred workflow 8.94 The issue I'm having is that when I type "enn" to make a note...I get the body of the note as the title of the note as well. I don't know how to separate this. I tried following your notation by putting a ":" at the start of the title and placing that before the body of the note as well as trying it by putting a ":" after and it always puts everything I type in its entirety in both the body and title of the note. What am I doing wrong?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...