Jump to content
Carlos-Sz

Evernote Workflow 9 beta 4 (Alfred 4)

Recommended Posts

I'm having some trouble with creating new notes. Every time I try I get an Error message telling me that the notebook name is case sensitive. I am just selecting the notebook from the list it provides so I don't understand how it's getting the letter case wrong. What am I doing wrong here?

Share this post


Link to post

Please, what is your Evernote app version? And what is your workflow version?

Make sure to use Evernote app from evernote.com and not from MAS.

I'm having some trouble with creating new notes. Every time I try I get an Error message telling me that the notebook name is case sensitive. I am just selecting the notebook from the list it provides so I don't understand how it's getting the letter case wrong. What am I doing wrong here?

Share this post


Link to post

Thank you for your quick response. I am using Evernote ver. 6.0.6. I downloaded Evernote 8.991 for the new Evernote 6.06. I'm not sure if I am using Evernote from evernote.com or the MAS. Please forgive my ignorance. Your help is greatly appreciated!

Share this post


Link to post

Thank you for your quick response. I am using Evernote ver. 6.0.6. I downloaded Evernote 8.991 for the new Evernote 6.06. I'm not sure if I am using Evernote from evernote.com or the MAS. Please forgive my ignorance. Your help is greatly appreciated!

 

I made a test here and it seems to be working fine.

 

First, make sure to install Evernote app from evernote.com (you can download it from there and reinstall it or open MAS app and see if Evernote is already “installed”).

 

If you have it from evernote.com please make a step by step here or using a private message so I can try to reproduce the issue.

 

Thank you.

Share this post


Link to post

I made a test here and it seems to be working fine.

 

First, make sure to install Evernote app from evernote.com (you can download it from there and reinstall it or open MAS app and see if Evernote is already “installed”).

 

If you have it from evernote.com please make a step by step here or using a private message so I can try to reproduce the issue.

 

Thank you.

I had installed the MAS versions, that was the problem. Thanks! It's working great now.

Share this post


Link to post

I've reported the append issue to Evernote: is there a bug tracking number or more details i can share with the support person, so that my issue can be added to other reports?

 

Ticket# 972678 - "Operation would exceed monthly upload allowance" on append action

Vincent S. (Evernote Support)

Mar 5, 12:39

Hi Judith,

Unfortunately, I'm not able to access the version of Alfred that you are using, so I cannot get more details on this bug.

Is it possible for you to get more details on the technical details from Alfred that are leading them to believe this to be an Evernote issue? That way, I can escalate to our technical team and get this resolved as quickly as possible.

Let me know!

Looking forward to hearing from you!

Regards,
Vincent S.

Share this post


Link to post

 

I've reported the append issue to Evernote: is there a bug tracking number or more details i can share with the support person, so that my issue can be added to other reports?

 

Ticket# 972678 - "Operation would exceed monthly upload allowance" on append action

Vincent S. (Evernote Support)

Mar 5, 12:39

Hi Judith,

Unfortunately, I'm not able to access the version of Alfred that you are using, so I cannot get more details on this bug.

Is it possible for you to get more details on the technical details from Alfred that are leading them to believe this to be an Evernote issue? That way, I can escalate to our technical team and get this resolved as quickly as possible.

Let me know!

Looking forward to hearing from you!

Regards,

Vincent S.

 

 

The append using AppleScript (not only using Alfred) is a known bug. I read in Evernote forum that an internal note about it was already done.

 

Unfortunately we have to wait.

 

Anyway, it is interesting to see how “well” Vincent S. is informed… :)

Share this post


Link to post

Hello Carlos. First of all, thanks for the great workflow!

 

I was wondering, are you thinking about adding the saved search support in the future?

 

It could be part of the "Search notes" results, or have it's own shortcut, eg. "enss my_saved_search_name".

Share this post


Link to post

Hi,

 

I have several notebooks stacks that contain a colon in the name (as in Main:subnotebook), and I've discovered that the search ent @Main:subnotebook :search terms fails because of the first colon in the notebook name (basically is searching for the term subnotebook in the Main notebook). Is there any way of escaping that colon so that the search works as expected?

 

Thanks in advance

Share this post


Link to post

I am using Alfred 2.7.1, Evernote 6.0.11, and workflow 8.991. When I type the search keyword, for example,  "ens" or "ent" or "enu", as soon as I type the last letter it opens Evernote. I'm not able to actually enter a search term. What am I doing wrong?

Share this post


Link to post

Strange, but now if tag is already present in evernote, it is missing for any new note created with enn:

 

example:

 

enn #newtag #existing-tag :Test note

 

Test note will have just newtag, and existing-tag is missing. If I add manually afterwards in evernote, it stays. 

 

The problem is not connected with latest version of Alfred 2 Evernote, but something with Evernote itself. Anyway, any hint where to check/how to fix with be be great.

Share this post


Link to post

I can't install this Workflow, i made a double-click, but it doesn't work.

 

Alfred 2, v2.7.1 (387)

Evernote 8.991 for the new Evernote 6.06

Edited by LeoneWang

Share this post


Link to post

Not sure why this happens to me, but the moment I type "en" in alfred, Evernote launches and the Alfred window closes

Therefore I can not use any of the features of the workflow. I am sure there is some kind of setting I am missing!

Share this post


Link to post

I am using Alfred 2.7.1, Evernote 6.0.11, and workflow 8.991. When I type the search keyword, for example,  "ens" or "ent" or "enu", as soon as I type the last letter it opens Evernote. I'm not able to actually enter a search term. What am I doing wrong?

 

Same setup and this is happening *sometimes* to me as well.

Share this post


Link to post

Hello Carlos. First of all, thanks for the great workflow!

 

I was wondering, are you thinking about adding the saved search support in the future?

 

It could be part of the "Search notes" results, or have it's own shortcut, eg. "enss my_saved_search_name".

 

There is no AppleScript commands for saved searches yet.

 

If I find something I’ll let you know.

 

Thank you for your feedback.

 

Hi,

 

I have several notebooks stacks that contain a colon in the name (as in Main:subnotebook), and I've discovered that the search ent @Main:subnotebook :search terms fails because of the first colon in the notebook name (basically is searching for the term subnotebook in the Main notebook). Is there any way of escaping that colon so that the search works as expected?

 

Thanks in advance

 

The workflow uses colon internally. I would have to change it completely in order to support the way you organize your notes.

 

Anyway, if I find a way I’ll let you know.

 

I am using Alfred 2.7.1, Evernote 6.0.11, and workflow 8.991. When I type the search keyword, for example,  "ens" or "ent" or "enu", as soon as I type the last letter it opens Evernote. I'm not able to actually enter a search term. What am I doing wrong?

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

 

Strange, but now if tag is already present in evernote, it is missing for any new note created with enn:

 

example:

 

enn #newtag #existing-tag :Test note

 

Test note will have just newtag, and existing-tag is missing. If I add manually afterwards in evernote, it stays. 

 

The problem is not connected with latest version of Alfred 2 Evernote, but something with Evernote itself. Anyway, any hint where to check/how to fix with be be great.

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

 

I'm also looking for a fix for the tags not showing up on a newly created notes. lidow, have you figured anything out?

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

 

 

I can't install this Workflow, i made a double-click, but it doesn't work.

 

Alfred 2, v2.7.1 (387)

Evernote 8.991 for the new Evernote 6.06

 

Please, restart your Mac, download the workflow again and try to install it one more time.

 

Not sure why this happens to me, but the moment I type "en" in alfred, Evernote launches and the Alfred window closes

Therefore I can not use any of the features of the workflow. I am sure there is some kind of setting I am missing!

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

 

Same setup and this is happening *sometimes* to me as well.

 

 

Having the same issues as other folks. The moment I type ens it's launching Evernote. I have removed and reinstalled the workflow and still get the same symptoms.

 

Evernote version: 6.0.11

Alfred version 2.7.1

 

OS X 10.10.3

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

Share this post


Link to post

I am using Alfred 2.7.1, Evernote 6.0.11, and workflow 8.991. When I type the search keyword, for example,  "ens" or "ent" or "enu", as soon as I type the last letter it opens Evernote. I'm not able to actually enter a search term. What am I doing wrong?

 

 

It seems to be working fine with Evernote 6.0.16

 

Please make some tests with the latest Evernote app.

 

Nope. As soon as I type the 's' in "ens", it opens evernote. Version 6.0.16 (451861 Direct)

Share this post


Link to post

Nope. As soon as I type the 's' in "ens", it opens evernote. Version 6.0.16 (451861 Direct)

 

When you say open you mean: 1) Evernote was already started and the workflow brings Evernote app to the foreground? or, 2) Evernote app was closed then the workflow starts Evernote app?

 

Note that the workflow depends on Evernote app (due AppleScript commands) and if it is closed then Evernote app will be started/opened.

Share this post


Link to post

What I've done is add Evernote as an app under "User & Groups" > Login

 

With the "hide" option ticked. This way Evernote starts on bootup and you don't get the issues as mentioned.

 

 

 

Carlos-Sz, I'm curious as to how "ent" works, I thought it would only search through the title of the notes, but that doesn't seem to be case (see attached screens for "ent" and "ens" comparisons). May be I'm understanding this wrong?

 

ent

http://imgur.com/1s1vinR,ozsgtcP#1

 

ens

http://imgur.com/1s1vinR,ozsgtcP

 

This is a brand new install of the latest plugin as of yesterday.

 

Again, brilliant plugin, really appreciate your work on it. It's been an indispensable tool for my daily use!

Share this post


Link to post

This workflow is really awesome! I can't live without this :)


 


One thing that is missing is to create a new note with an unfinish reminder set (reminders without date).  


 


Let me explain how i use evernote. I tweak evernote to act like a GTD app. Newly created note is considered as a single todo item. So i need to set reminder for each note i created. For now, I have created a save search that will query all the notes (created using ENN) that don't have an unfinish reminder yet, and set reminder (w/o date) each note one by one every morning before i start the day. 


 


One solution is to set !today for each note i create:


enn #todoGrocery !today Buy Milk


 


This will work but not that ideal since i dont want to set date. I need to mark the created note "Buy Milk" to have an unfinished reminder (w/o date), this will make all notes in #todoGrocery sortable. Sortable item is important to me.


 


I hope there's an option for the newly created note to have an unfinish reminder set in default, or something like


enn #todoGrocery !reminder Buy Milk


 


Any idea?


Share this post


Link to post

Hello,

 

I really love this workflow but it doesn't work as I expected. My problem is similar to ToBeFrank: when I enter ens term to Alfred then it is immediately opening Evernote in foreground. But Evernote is already works on backround. Why it's opening again?

 

I'm using Evernote Version 6.1.1 (452254 App Store) and Alfred 2.8 (414) on OS X El Capitan.

Edited by fatihturan

Share this post


Link to post

Issue when creating notes from Safari URL. "enn :Test the west" always create note where the URL is in the title. My title is lost. Running EN Version 6.2 (452688 Direct).

 

Any ideas on how to fix it?

Share this post


Link to post

Of course, beautiful workflow 8.991, working great with Evernote 6.2, ... Many thanks,

 

Ennt, is working just fine for me, I have a few templates working from a Templates notebook, but I would like to understand how to use the edrstone, on 26 May 2014 - 9:49 PM, template, http://www.alfredforum.com/topic/840-evernote-8991-evernote-606-support-search-create-append-set-reminders-all-within-alfred/page-21, ... I just get a note with the script, not a note configured according to the script, ... Maybe I am not interpreting this correctly, though, Thanks

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...