Jump to content

Evernote Workflow 9 beta 4 (Alfred 4)


Recommended Posts

@hansvveen I've had a look and it appears that Evernote 7 was released two days ago. As it's brand new, there's a good possibility that something in Evernote has changed (e.g. how/where the data is stored), which could require an update to @Carlos-Sz's workflow. 

 

As I haven't yet updated to Evernote 7, I can't check what's changed directly. 

 

First, could you check whether your Evernote data is still stored in ~/Library/Application Support/com.evernote.Evernote/accounts/ which is where my Evernote 6 data appears to be stored? This would be a helpful starting point. :)

Link to post
  • Replies 813
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Alfred 4 Read about this workflow below.   This is an update to address the new Alfred 4 data folder (thanks to xilopaint). DOWNLOAD   Description Alfred 3 workflow

Evernote workflow 9 beta 3 released with minor code optimizations and updated workflow preferences.   Download Now   If your search (ens keyword) is not returning any results pleas

@All:   Here is a very early version of the workflow that starts to add support to Evernote 6.06+. There are a lot of code lines to review and test so there is a chance that something still needs to

Posted Images

9 hours ago, hansvveen said:

I've installed the most recent workflow and recent version of Evernote from the website (version 7). I'm having the same problem as described earlier in this thread. The search opens a google search instead of Evernote. I've tried to install an older version of Evernote (6) but I'm not able to run it as it is not compatible with my version 7 data. Any suggestions? 

 

 

If Evernote 7 has changed everything then I'm not sure when I will be able to update the workflow.

 

Note, however, that earlier Evernote versions may have bugs that prevent the workflow from working properly.

Link to post
1 minute ago, deanishe said:

 

It may be helpful to share some details about the machines, such as which version of macOS they’re running.

 

Sure thing. 

 

Works on older MacBook Pro 2012 running 10.13.3

 

Not working on newer MacBook Pro 2017 running same 10.13.3.

 

I get the following error in debug:

Starting debug for 'Evernote'

[2018-02-20 21:54:33][ERROR: input.scriptfilter] Code 1: 0:90: execution error: System Events got an error: 'Macintosh HD:Users:NAME:Library:Application Support:Alfred 3:Workflow Data:com.sztoltz.evernote:settings.plist' is not a property list file. (-1728)

Any insights would be appreciated!

Link to post
50 minutes ago, JoeyBloggs said:

Any insights would be appreciated!

 

The error is fairly clear: the settings.plist file is borked on that machine. Which would explain why it doesn't work there, but does on your other machine…

 

Take this advice with a big pinch of salt because I don't use Evernote or the workflow, but you could try renaming the offending settings.plist file (so the workflow ignores it) or copying the settings.plist file from the machine where the workflow works to the one where it doesn't.

Link to post
10 hours ago, deanishe said:

 

The error is fairly clear: the settings.plist file is borked on that machine. Which would explain why it doesn't work there, but does on your other machine…

 

Take this advice with a big pinch of salt because I don't use Evernote or the workflow, but you could try renaming the offending settings.plist file (so the workflow ignores it) or copying the settings.plist file from the machine where the workflow works to the one where it doesn't.

 

Thanks I'll try that.

Link to post

Whenever I append, it appends the text I want, but also strangely the url of the website i'm on. Any idea what's going on there?

 

1. ens My Note
2. arrow down to "My Note"
3. hold cmd to append
4. hit enter
5. arrow down to type text
6. type text "Hello World"

7. enter

result is my note says
"Hello World" and then "website_that_i'm_currently_on.com"

I also can't figure out how to use the optional syntax. it seems to just not work.

Link to post
17 hours ago, jarvisjarvis said:

additionally, when i create notes, i'm noticing my titles/bodies are being truncated, like "Hello World" becomes "Hello Wo", any advice?

 

As I wrote above, maybe Evernote 7.0 has changed, and thus braking the workflow (that was made for Evernote 6.x), or it's an Evernote 7.0 bug.

 

Link to post

@all

 

I've installed Evernote 7.01 and my tests indicate that Evernote is returning an empty list when the command find notes is used along with a query string.

 

In resume, Evernote 7 is not working properly and there is nothing I can do.

 

Let's all wait, again, for Evernote to fix something that was working before. :D

Link to post

I've contacted Evernote support by Twitter and didn't hear back from them, so I've emailed support to find out what's changed and how we can get this wonderful workflow working again. As soon as I have anything to report, I'll pass that on to @Carlos-Sz and pop an update here too :)

 

In the meantime, for those who want an uninterrupted service, if you catch this before updating to Evernote 7, stay on Evernote 6 until further notice.

 

Cheers,
Vero

Link to post
2 minutes ago, hansvveen said:

I've checked: ~/Library/Application Support/com.evernote.Evernote/accounts/ which is where my Evernote 6 data appears to be stored?
and cannot finbd Evernote data there.

 

Just to clarify: This location is only applicable for Evernote 6 downloaded from the Evernote.com website. If you've downloaded Evernote 6 from the App Store, the data is somewhere else, and isn't compatible with the workflow.

 

As soon as I hear back from Evernote, we'll let you all know what the status is :) 

Link to post
  • 2 weeks later...
On 26/02/2018 at 1:00 PM, hansvveen said:

Thanks all so far.
I've checked: ~/Library/Application Support/com.evernote.Evernote/accounts/ which is where my Evernote 6 data appears to be stored?
and cannot finbd Evernote data there.

 

Hopefully the workflow will be updated to Evernote 7.

 

Did you check:

~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts

 

 

Link to post
  • 2 months later...
53 minutes ago, vivekrp said:

Any idea when it will work with Evernote 7?

 

It works fine with Evernote 7 for me (v9 beta 1, Evernote 7.2, Alfred 3.6.1, macOS 10.13.5), at least the functions I use (mainly searching using the 'ens' and 'ent' commands).

Edited by cands
Link to post
On 6/7/2018 at 3:57 PM, cands said:

 

It works fine with Evernote 7 for me (v9 beta 1, Evernote 7.2, Alfred 3.6.1, macOS 10.13.5), at least the functions I use (mainly searching using the 'ens' and 'ent' commands).

It started working for me as well after complete uninstall of Evernote from App Store & installing from their website. @Carlos-Sz Thanks for this superb workflow & thanks @Vero for this awesome Alfred :)

Link to post
  • 2 weeks later...
On 6/7/2018 at 6:34 AM, Vivek Rp said:

Any idea when it will work with Evernote 7?

 

 

In Evernote app: To trigger a full index rebuild; Option-Key Help > Troubleshooting > Recreate

 

https://discussion.evernote.com/topic/111872-search-function-not-working/?do=findComment&comment=495182

 

It fixed the issue here.

Edited by Carlos-Sz
Link to post
  • 5 weeks later...
  • 2 weeks later...
  • 1 month later...

Friends can you help me. 
After mac os update to 10.14, evernote workflow doesn't work. On 'ens' type i didn't see notes - only search engines like 'google', 'wiki' etc.

I have tried to:
reinstall alfred
reinstall evernote
update and reinstall evernote workflow 
add alfred and evernote apps to security permissions 


 

2018-10-04_11-46-11.png

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...