Kitty Zenner

iOS device can not see Mac

6 posts in this topic

1) Both iOS device and Mac are connected to the same WiFi (MAC: IP:192.168.1.6 subnetmasker 255.255.255.0 router: 192.168.1.1, IOS: IP:192.168.1.2 subnetmasker 255.255.255.0 router: 192.168.1.1)

2) we use our Home network

3) I restarted Mac and IOS device

4) iOS device can not see Mac

5)I allowed Alfred as incomming network connections, to my knowlage i do not use network-restriction applications.

I have tried it with my iPhone and the iPad, Both do not work.

I tried it by direct connection, does not work.

I tried it by Bluetooth, but for Some reason i can not make a Bluetooth connection.

How can I make the remote connection? Thanks

Share this post


Link to post

Have you tried to ping your iPhone or iPad via terminal ? Other than that it could be that your router is blocking the Port Alfred is using.

So you could check your router options and open the Port or change alfreds used Port to one that is free. I'm using Port 50377 for instance.

 

Check under Activity Control if the task "Alfred Remote Server" is running. If not then start the server again or check what its blocking :)

 

Oh and here is a link for the bluetooth connection: https://www.alfredapp.com/help/remote/setting-up/bluetooth/

Edited by FroZen_X

Share this post


Link to post

tried to ping ( never did this before ;) )

My mac tells me that all the pack that are transmitted are received, no packet loss

iphone tells the same story. What does this mean? 

 

For the moment Alfred is using port 62378 however I have no idea how to check whether this port is blocked.

 

I checked activity controle, Alfred Remote server seems to be running (it records CPU and treads).

Share this post


Link to post

The pinging is just so that you know that your mac sees and can connect to your iPhone or iPad. 

When pinging works and the server is running then i assume that your router might be blocking the port. 

You can go to your Router settings via typing into your browser "192.168.1.1" in your case. That should bring you to 

your Routers login page. There you have to login and check where ports are handled. If you don't know the password then take a 

look at the backside of your router. The password should usually stay there unless you changed it before at some point. 

Other than that you can check for your router online. What ports are open from the start on and try changing Alfred Remote Server Port.

 

Other question would be how you try to connect to your device like the steps ? 

 

Else you can also take a look here: https://www.alfredapp.com/help/troubleshooting/remote/

Maybe some of these steps help you :)

Share this post


Link to post
It would be very unusual for a router to block ports for internal LAN traffic. It's much more likely that the computer is blocking the connection.
 

 

Are you using a manual connection or trying to connect automatically?

Share this post


Link to post

How could i be so silly lol. Was thinking about my own problems related to some other connection issues Port wise. 

It could be that Alfred Remote Server isn't in the Firewall list, to let incoming connections go through.

 

To check that open System Preferences->Security&Privacy->Firewall->Firewall Options(has to be unlocked by the lock at the bottom left)

There check if you see Alfred Remote Server and if incoming connections is green.

Should look like this:

2a918xg.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now