Jump to content
deanishe

Searchio! Auto-suggestion from search engines in different languages

Recommended Posts

50 minutes ago, Ligeard said:

You're right, I did it wrong!

 

Nope, you did it right. There was a bug in the import. Fixed in v2.0.1. Download it or use searchio up to update from within the workflow.

 

Thanks for finding the bug!

 

(You'll also need to delete your existing Qwant search and re-import it.)

 

Edited by deanishe

Share this post


Link to post
On 10/6/2018 at 6:32 PM, Ligeard said:

Yes! Thanks a lot!!

It works very well! :D 

 

I can now use Qwant ;) 

 

I'm grateful for the time spent helping us :) 

Can you show screenshots with Qwant search?

Share this post


Link to post
On 2/2/2019 at 5:25 PM, Simbin said:

Can you show screenshots with Qwant search?

Sorry... I didn't see your request!

 

 

Capture d’écran 2019-03-02 à 11.04.00.png

Share this post


Link to post
Posted (edited)

After updating to Alfred 4, Searchio stopped working. 😱 Below is the log I get. I suppose one has to replace "Alfred 3" with "Alfred 4" or something similar, but I have no idea where. Searchio and Alfred are both up do date.

[14:57:29.065] Logging Started...
[14:57:34.577] Searchio![Script Filter] Queuing argument 't'
[14:57:34.657] Searchio![Script Filter] Queuing argument 'te'
[14:57:34.684] Searchio![Script Filter] Script with argument 't' finished
[14:57:34.689] ERROR: Searchio![Script Filter] Code 1: 🍺
14:57:34 workflow.go:304: --------- Searchio!/2.0.1 (AwGo/0.14.0) ----------
14:57:34 search.go:127: loading search from /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json ...
14:57:34 feedback.go:453: Sent 1 result(s) to Alfred
14:57:34 workflow.go:352: [ERROR] open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory
14:57:34 workflow.go:380: ------------------- 3.613668ms -------------------
[14:57:34.738] Searchio![Script Filter] {
  "variables": {
    "AW_SESSION_ID": "F6ZR89F1TSRJPI272M5P96Z4"
  },
  "items": [
    {
      "title": "open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory",
      "valid": false,
      "icon": {
        "path": "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns"
      }
    }
  ]
}
[14:57:34.758] Searchio![Script Filter] Queuing argument 'tes'
[14:57:34.788] Searchio![Script Filter] Script with argument 'te' finished
[14:57:34.796] ERROR: Searchio![Script Filter] Code 1: 🍺
14:57:34 workflow.go:304: --------- Searchio!/2.0.1 (AwGo/0.14.0) ----------
14:57:34 search.go:127: loading search from /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json ...
14:57:34 feedback.go:453: Sent 1 result(s) to Alfred
14:57:34 workflow.go:352: [ERROR] open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory
14:57:34 workflow.go:380: ------------------- 1.294646ms -------------------
[14:57:34.799] Searchio![Script Filter] {
  "variables": {
    "AW_SESSION_ID": "QSDKE4EPA5JBFFZZSPOU4YMQ"
  },
  "items": [
    {
      "title": "open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory",
      "valid": false,
      "icon": {
        "path": "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns"
      }
    }
  ]
}
[14:57:34.840] Searchio![Script Filter] Queuing argument 'test'
[14:57:34.888] Searchio![Script Filter] Script with argument 'tes' finished
[14:57:34.897] ERROR: Searchio![Script Filter] Code 1: 🍺
14:57:34 workflow.go:304: --------- Searchio!/2.0.1 (AwGo/0.14.0) ----------
14:57:34 search.go:127: loading search from /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json ...
14:57:34 feedback.go:453: Sent 1 result(s) to Alfred
14:57:34 workflow.go:352: [ERROR] open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory
14:57:34 workflow.go:380: ------------------- 869.835µs -------------------
[14:57:34.900] Searchio![Script Filter] {
  "variables": {
    "AW_SESSION_ID": "F6ZR89F1TSRJPI272M5P96Z4"
  },
  "items": [
    {
      "title": "open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory",
      "valid": false,
      "icon": {
        "path": "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns"
      }
    }
  ]
}
[14:57:34.981] Searchio![Script Filter] Script with argument 'test' finished
[14:57:34.993] ERROR: Searchio![Script Filter] Code 1: 🍺
14:57:34 workflow.go:304: --------- Searchio!/2.0.1 (AwGo/0.14.0) ----------
14:57:34 search.go:127: loading search from /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json ...
14:57:34 feedback.go:453: Sent 1 result(s) to Alfred
14:57:34 workflow.go:352: [ERROR] open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory
14:57:34 workflow.go:380: ------------------- 1.087016ms -------------------
[14:57:34.996] Searchio![Script Filter] {
  "variables": {
    "AW_SESSION_ID": "QSDKE4EPA5JBFFZZSPOU4YMQ"
  },
  "items": [
    {
      "title": "open /Users/jakub/Library/Application Support/Alfred/Workflow Data/net.deanishe.alfred-searchio/searches/wikipedia-en.json: no such file or directory",
      "valid": false,
      "icon": {
        "path": "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns"
      }
    }
  ]
}

 

Edited by Jakub Sypiański

Share this post


Link to post
3 hours ago, Jakub Sypiański said:

I suppose one has to replace "Alfred 3" with "Alfred 4" or something similar

 

No, search still works. The problem is that your search configurations are all in Alfred 3's directory.

 

Copy the contents of /Users/jakub/Library/Application Support/Alfred 3/Workflow Data/ to /Users/jakub/Library/Application Support/Alfred/Workflow Data/ and it should work.

Share this post


Link to post

I reinstalled my system, I have the problem again, but now in "Application Support" I have only "Alfred", not "Alfred 3" or "Alfred 4". And the folder with the workflow is not there. So I guess my settings are gone and I cannot retrieve them, can I?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...