Jump to content

Alfred doesn't show over iTerm2 hotkey window


NSDmitry
 Share

Recommended Posts

I use iTerm2 hotkey window feature, to pop iTerm console on top of the screen (similar to TotalTerminal or Quake console), and if iTerm2 hotkey window is active and I press "Opt+Space" Alfred Window shows up and immediately disappear, so I'm typing command to nowhere. If iTerm2 hotkey window is not active, than Alfred shows up as it should, without disappearing.

 

Alfred 3.0 (Build 652)

OS X 10.11.5

iTerm2 2.9.20160206

Edited by NSDmitry
Link to comment
Share on other sites

It looks like something has changed in the OS which prevents iTerm2 from detecting Alfred correctly (it has special support built in to detect this, but it seems to have stopped working).

 

There is a workaround: In iTerm2, go to Preferences > Advanced. Turn on "Prevent opening Spotlight from auto-closing the hotkey window". This is an experimental feature but it seems to fix the issue with Alfred. I'll rename it in the next version to name Alfred and then turn it on by default shortly after.

Link to comment
Share on other sites

Thanks a lot for you response! It helped! Now Alfred appears correctly.

 

There is on small issue it produces - if Alfred shows on top of iTerm2 hotkey window, and I use hotkey for iTerm2 again - both windows disappear (Alfred and iTerm2). But anyway I can live with that. Thanks again!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...