Jump to content

Alfred Remote won’t connect to server after updating to Alfred 3


onyxleopard
 Share

Recommended Posts

I updated to Alfred 3 and now I cannot connect to the server via the Alfred Remote iOS app.

 

iOS version info:

9.3.2

 

OS X version info:

ProductName: Mac OS X
ProductVersion: 10.11.5
BuildVersion: 15F34
 
Alfred 3 version info:
v3.0 [652]
 
My server shows up in the remote app when I click the ‘Add iOS Remote’ button in Alfred 3’s preferences, however, then it just sits at ‘Connecting…’ in Alfred Remote, and ‘Waiting for Alfred Remote…’ in Alfred 3.
 
I’ve tried uninstalling and reinstalling the apps on both iOS and OS X.  I tried removing the server and re-adding it.  I tried disabling and re-enabling the server and restarting the server.  I get the same results no matter what.  If Alfred Remote does not work with Alfred 3, you should have given a warning that the remote app will break before prompting to upgrade.
Edited by onyxleopard
Link to comment
Share on other sites

My firewall wasn’t blocking it before…  Nothing has changed besides upgrading to Alfred 3—it’s the only variable here.

 

Just trying to help...ahem anyway have you tried to direct connect?

I just deleted my devices and reconnected them without any issue, therefore I'm asking for other variables.

Link to comment
Share on other sites

I see the problem (thanks FroZen_X).  Since the server is embedded in the Alfred 3 app bundle I had to add it to the system firewall whitelist (the rule for the Aflred 2 remote server did not carry over).  Kind of annoying.

 

Glad i could help :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...