Jump to content

Recommended Posts

What is your calendar and date format in System Preferences > Language & Region?

 

Chinese (Taiwan) 

 

CapturFiles-201309262_0209.png

 

I've tested that if I change my format to English (US), the test is correct and almost all functions are working ._.; 

Edited by kengao

Share this post


Link to post

Sorry… in this case I don't think I can help.

 

Edit: on second thoughts I can probably fix the immediate problem you have, but i think the workflow might still break. let me get back to you.

Edited by Jack James

Share this post


Link to post

This is a great workflow -- very useful and feature-ful. Thanks for making it! I especially like that I can add reminders with reference to the doc in the current application. Very cool

 

The only thing on my wish list is that reminders were ordered by due date.

 

Keep up the good work!

Share this post


Link to post

Hello! 

Thanks a lot for the super workflow!

 

I have however a problem on my Mac Pro running Mac OS 10.8.5

 

I changed in all the three Applescript the default list to the one I want to use (Work).

 

I can add correctly new todo, but when I try to watch open ones I only see the ones of the default list.

In no way I can see the one open in Work.

 

If I run rtest I get:

 

Test results:
OS version: 10.8.5 (0 seconds)
Current date: mardi, 8 octobre 2013 09:14:09 (0 seconds)
Initialize workflow path: /Users/mcastelli/Dropbox/Alfred2/Alfred.alfredpreferences/workflows/user.workflow.AB91C0D1-DDFF-4C15-8D60-DE79AEC3B639 (0 seconds)
Initialize alfred-library: OK (0 seconds)
Initialize update-library: OK (0 seconds)
Initialize wf-library: OK (0 seconds)
Initialize plist-library: OK (0 seconds)
Reminders.app state: Running (0 seconds)
Fetch reminder count: 4 (0 seconds)
Fetch reminder info: OK (0 seconds)
Fetch reminder list count: 3 (0 seconds)
Fetch reminder list info: OK (0 seconds)
Run cache process: ERROR: /Users/mcastelli/Dropbox/Alfred2/Alfred.alfredpreferences/workflows/user.workflow.AB91C0D1-DDFF-4C15-8D60-DE79AEC3B639/cache-reminders.scpt: execution error: Can't setKey: System Events got an error: Can’t set property list item "cacheInProgress" of contents of property list file "/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist" to 0.-10006 (-10006) (0 seconds)
Fetch cache timestamp: mardi, 8 octobre 2013 09:06:39 (0 seconds)
Fetch cached reminder count: 3 (0 seconds)
Test basic query: OK (0 seconds)
Test today query: OK (0 seconds)
Test in n minutes query: OK (0 seconds)
Test in n hours query: OK (0 seconds)
Test in n days query: OK (0 seconds)
Test in n days y hours query: OK (0 seconds)
Test in n hours y minutes query: OK (0 seconds)
Test at time query: OK (0 seconds)
Test tomorrow at time query: OK (0 seconds)
Test in x list query: OK (0 seconds)
Subtitle generation: OK (0 seconds)
Test basic reminder filtering: OK (0 seconds)
Test remind today reminder filtering: OK (0 seconds)
Test due tomorrow reminder filtering: OK (0 seconds)
Test reminder list filtering: OK (0 seconds)
Test version-check response: OK (0 seconds)
Current unix time: 1.381216449E+9 (0 seconds)
Simple JSON: OK (0 seconds)
Test execution time: 0 seconds
 
 
 
Any idea?
 
Matteo
 

Share this post


Link to post

 

Hello! 

Thanks a lot for the super workflow!

 

I have however a problem on my Mac Pro running Mac OS 10.8.5

 

I changed in all the three Applescript the default list to the one I want to use (Work).

 

I can add correctly new todo, but when I try to watch open ones I only see the ones of the default list.

In no way I can see the one open in Work.

 

If I run rtest I get:

 

Run cache process: ERROR: /Users/mcastelli/Dropbox/Alfred2/Alfred.alfredpreferences/workflows/user.workflow.AB91C0D1-DDFF-4C15-8D60-DE79AEC3B639/cache-reminders.scpt: execution error: Can't setKey: System Events got an error: Can’t set property list item "cacheInProgress" of contents of property list file "/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist" to 0.-10006 (-10006) (0 seconds)
 
 
 
Any idea?
 
Matteo

 

Can you check that the file at 

/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist

 

exists?

 

From Finder, choose Go > Go To Folder… 

enter /Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/

 

There should be a file called cache.plist there. Let me know.

Share this post


Link to post

Hi Jack,

 yes the file exists:

 

matteo:mcastelli$ ls -la "/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist"
 
-rw-r--r--  1 mcastelli  staff  1431  8 oct 14:24 /Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist
 
I renamed it and now I can see the current tasks, *but* I still get the same error in rtest *and* if I add some new tasks I cannot see them anymore.
It seems the first caching runs fine but then something stops to update it
 
Matteo
 

 

Can you check that the file at 

/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist

 

exists?

 

From Finder, choose Go > Go To Folder… 

enter /Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/

 

There should be a file called cache.plist there. Let me know.

Share this post


Link to post

Hi Jack,

 

I am installing for the first time today and seem to have a similar problem. 

 

Run cache process: ERROR: /Users/david/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.EEE1F01F-D88C-4B35-A550-F97F57A8EF9C/cache-reminders.scpt: execution error: Can't setKey: System Events got an error: Can’t set property list item "cacheInProgress" of contents of property list file "/Users/david/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist" to 0.-10006 (-10006) (0 seconds)

 

ls -la ~/Library/Application\ Support/Alfred\ 2/Workflow\ Data/com.surrealroad.alfred-reminder/cache.plist produces

 

-rw-r--r--  1 david  staff  321  9 Oct 11:48 /Users/david/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist

 

Thanks

David

 

Share this post


Link to post

Jack,

 

If it helps the contents of my

 /Users/david/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist

didn't have a "cacheInProgress" key so I added one as

<dict>
...
<key>cacheInProgress</key>
<integer>0</integer>
</dict>

that seems to have resolved my problem.

 

:D

Share this post


Link to post

 

Hi Jack,

 yes the file exists:

 

matteo:mcastelli$ ls -la "/Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist"
 
-rw-r--r--  1 mcastelli  staff  1431  8 oct 14:24 /Users/mcastelli/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist
 
I renamed it and now I can see the current tasks, *but* I still get the same error in rtest *and* if I add some new tasks I cannot see them anymore.
It seems the first caching runs fine but then something stops to update it
 
Matteo

 

 

 

 

Hi Jack,
 
I am installing for the first time today and seem to have a similar problem. 
 
Run cache process: ERROR: /Users/david/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.EEE1F01F-D88C-4B35-A550-F97F57A8EF9C/cache-reminders.scpt: execution error: Can't setKey: System Events got an error: Can’t set property list item "cacheInProgress" of contents of property list file "/Users/david/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist" to 0.-10006 (-10006) (0 seconds)
 
ls -la ~/Library/Application\ Support/Alfred\ 2/Workflow\ Data/com.surrealroad.alfred-reminder/cache.plist produces
 
-rw-r--r--  1 david  staff  321  9 Oct 11:48 /Users/david/Library/Application Support/Alfred 2/Workflow Data/com.surrealroad.alfred-reminder/cache.plist
 
Thanks
David
 

 

 

Both: thanks for the feedback. Please download the latest version which fixes this issue.

Share this post


Link to post

Jack, I'm having some problems using this workflow with the Mavericks GM. First, in the Privacy panel in SysPrefs, the osascript opion is not available.

 

Second, using the default of "r" and using the syntax you've described opens a search in Chrome, and doesn't create a Reminder. As an example, r at noon to Check Twitter simply sends the line to Chrome as a search.

 

Any ideas what's happening??

Share this post


Link to post

Jack, I'm having some problems using this workflow with the Mavericks GM. First, in the Privacy panel in SysPrefs, the osascript opion is not available.

 

Second, using the default of "r" and using the syntax you've described opens a search in Chrome, and doesn't create a Reminder. As an example, r at noon to Check Twitter simply sends the line to Chrome as a search.

 

Any ideas what's happening??

 

 

Several things:

  • Most importantly: OS 10.9 is not supported right now, due to a bug in osascript (which Alfred uses to run Applescript) meaning that every Applescript request is taking 15x longer than it should. I've logged this with Apple, maybe it will get sorted maybe not. All my Macs are now 10.9 GM so I'm just as keen to get this sorted! That said, the workflow *should* still work, it'll just be very slow.
  • The specific problem you're exhibiting sounds like an issue with a previous version of this workflow, where it would crash when requesting the list of outstanding reminders. Do you have the latest version (last updated October 9)? If you do, can you run "rtest" and send me the results?
  • You might not see "osascript" in System Preferences > Privacy until the workflow tries to run once successfully. Even then, you might not see it at all, that might only happen when I try to debug it.

EDIT: I just noticed Apple did something a bit daft and released a new GM that I can't upgrade to. Can you let me know which GM build you're using?

Edited by Jack James

Share this post


Link to post

Jack, I'm running 13A603 which was posted yesterday. For the record, you can get it via the MAS. When you try and download it it'll tell you that you already have it installed and do you want to re-download the entire installer. Click continue and after it's reinstalled, you'll see you have 13A603.

 

Yes, I'm running 2.09, build 214 of Alfred.

 

Here is the rtest you requested.

 

Also, am I missing something that I can't insert a time into the RADD line. As an example, RADD Today at noon Call Jack James. As soon as I enter time it turns into a Google search, which is my default for unrecognized text in Alfred.

Share this post


Link to post

Jack, I'm running 13A603 which was posted yesterday. For the record, you can get it via the MAS. When you try and download it it'll tell you that you already have it installed and do you want to re-download the entire installer. Click continue and after it's reinstalled, you'll see you have 13A603.

 

Yes, I'm running 2.09, build 214 of Alfred.

 

Here is the rtest you requested.

 

Also, am I missing something that I can't insert a time into the RADD line. As an example, RADD Today at noon Call Jack James. As soon as I enter time it turns into a Google search, which is my default for unrecognized text in Alfred.

"noon" is not a recognized keyword, and you need to include the keyword "to" when constructing commands with specific times.

 

try "radd today at 12pm to call Jack James"

 

--

From your log file, it seems that you have an unsupported scripting addition (/Library/ScriptingAdditions/QXPScriptingAdditions.osax). It shouldn't affect this workflow, but it might trip something up, so you might want to delete it.

 

It also looks like your cache file might be corrupted, I've built a new version of the workflow which will check for this and recreate the file as needed.

 

--

I've updated to the latest GM (thanks for that) so I should be in sync with what you're seeing (for the record, they haven't fixed the osascript bug, so it'll still be slow). In addition, Alfred notifications don't seem to be working at all in this latest build of OS X :(

 

Anyway, I've run into the same problem as you with the cache process completely crashing and corrupting the cache file. It seems that another bug has been introduced since the last GM (sigh), meaning it's no longer possible to create arrays/lists in plists via System Events.

 

I've made a workaround for this which seems to work (and hopefully won't break it for everyone on other versions of OS X…), download the latest version.

Share this post


Link to post

Jack, thanks for all the detective work! The QXPScriptingAdditions.osax is most likely a remnant of a version of QuarkXpress I had installed a few years ago and removed. I deleted the file this morning but it hasn't made much difference one way or the other.

 

There are a couple compatibility problems with Alfred that Mavericks has introduced. Besides notifications, definitions are also broken because Spotlight now handles them differently.

 

No change in the process of trying to add a reminder with the updated workflow. Here's a quick screen shot of what happens when I try and add "RADD on today 12:01pm Call Jack James". The only successful way I've found to get your script to work is to use "RADD today Call Jack James".

 

Hopefully Apple will get this sorted out quickly. I see they closed the beta program on Mavericks yesterday which means there should be a new one opening for 10.9.1 in the very near future. If the osax problem isn't fixed at the release of that build, I, too, will file a ticket with development and see if we can't get their attention!

Edited by bocaboy

Share this post


Link to post

No change in the process of trying to add a reminder with the updated workflow. Here's a quick screen shot of what happens when I try and add "RADD on today 12:01pm Call Jack James". The only successful way I've found to get your script to work is to use "RADD today Call Jack James".

 

"radd today at 12:01pm to call Jack James" doesn't work?

 

"r help" should show similar examples. If there's no description below each example when you do this then something's broken

Edited by Jack James

Share this post


Link to post

Yep, that syntax works! I was using your guide to usage on the first page of this string, third from the bottom. I should have looked at the very last one!

 

ok, so that pattern ("r on 31-12-99 23:22 to panic about the millennium bug") is if you want to specify date/time as a timestamp format, i.e. dd-mm-yy hh:mm

Share this post


Link to post

Jack, so here's something that may be interesting regarding notifications. I also use your Notes workflow and DID receive a notification, as I would have expected, when I entered one this morning.

Share this post


Link to post

Jack, so here's something that may be interesting regarding notifications. I also use your Notes workflow and DID receive a notification, as I would have expected, when I entered one this morning.

something strange is happening with notifications. They were working fine in GM1, and like you, they worked for me in notes– which also seemed to trigger *all* the previous alfred notifications to suddenly appear. Since then, notifications in the reminders workflow do seem to be working for me. I am still not receiving notifications from other applications though :/

 

Try adding another reminder and see if you get a notification now.

Share this post


Link to post

Well, the notification showed up, but there's now a problem with time not showing up correctly during entry. Take a look at this one where I use the actual time as PM and which shows up as AM. The other uses the keyword NOON which isn't recognized.

Share this post


Link to post

I suspect you are trying to add a reminder in the past in the first instance (if you want to do that you need to be explicit about the date).

"Noon" is not recognised by this workflow (nor is "midnight"). I can probably add it.

 

Edit: looks like there's a bug with 12am/pm. I'm looking into it.

Edited by Jack James

Share this post


Link to post

Jack, we're in different time zones so October 23 at 12:01PM is still about 2 hours off for me, more at the time of the screen capture. My own 2¢ would be that noon, midnight, and tomorrow would be good to add.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...