Jump to content

can't configure itunes due to no library xml


Recommended Posts

Hi,

 

Alfred's iTunes integration isn't doing anything for me:

 

00000003.png

 

OK, so let's look...

 

00000004.png

 

You can see in this screencast that the "Find" button doesn't do anything.

 

I'll need to find that file myself.  The problem is it doesn't exist:

$ find ~ -name 'iTunes Library*'
/Users/boneskull/Music/iTunes/iTunes Library Extras.itdb
/Users/boneskull/Music/iTunes/iTunes Library Genius.itdb
/Users/boneskull/Music/iTunes/iTunes Library.itl

Of note, all of my music is in iTunes Match.

 

Is there some way to create this file?

 

- Mac OS 10.11.5 (15F34)

- Alfred 3.0.2 (676)

- iTunes 12.4.1.6

 

Link to post
Share on other sites

Hi,

 

Alfred's iTunes integration isn't doing anything for me:

 

 

You can see in this screencast that the "Find" button doesn't do anything.

 

I'll need to find that file myself.  The problem is it doesn't exist:

$ find ~ -name 'iTunes Library*'
/Users/boneskull/Music/iTunes/iTunes Library Extras.itdb
/Users/boneskull/Music/iTunes/iTunes Library Genius.itdb
/Users/boneskull/Music/iTunes/iTunes Library.itl

Of note, all of my music is in iTunes Match.

 

Is there some way to create this file?

 

- Mac OS 10.11.5 (15F34)

- Alfred 3.0.2 (676)

- iTunes 12.4.1.6

 

 

First, have you enabled the third-party sharing in iTunes?

 

See the third checkbox in this screenshot:

https://www.alfredapp.com/help/troubleshooting/itunes/#xml

 

Then you'll need to ensure that there is music in the XML created; Provided the music is stored locally, it should be included :)

 

Cheers,

Vero
Link to post
Share on other sites
  • 2 weeks later...
×
×
  • Create New...