Jump to content

Not finding app names until 3rd or 4th identical search


Recommended Posts

I've been using Alfred 3 with the Sierra beta for a few weeks now with no problems. 2 days ago, I decided to do a clean install of Sierra on my MacBook and Alfred was one of the first things to get reinstalled. Since then, however, getting app names to come up has been REALLY slow.

 

If I start typing the name of an app, all I'll get are the default Search Google/Amazon/Wikipedia results. If I try it again, the same thing happens. Usually after the 3rd or 4th try, it'll finally show the application as expected and I'll be able to launch it. Once it finds it once, it appears to be fine until the next time I restart the computer at which point it'll "forget" all over again.

 

What's really strange is that using Spotlight, app names come up immediately. Since, to the best of by knowledge, Alfred uses the exact same data source as Spotlight, I really don't know what could be causing this. Any help would be appreciated.

Link to post

So using "reload" seems to only make it "forget" the ones that I've gotten it to remember. I used Alfred to launch Chrome earlier, and when I tried it again after doing a "reload" I had to do the retype it 3-4 times thing to get it to show up again.

Link to post

I've been using Alfred 3 with the Sierra beta for a few weeks now with no problems. 2 days ago, I decided to do a clean install of Sierra on my MacBook and Alfred was one of the first things to get reinstalled. Since then, however, getting app names to come up has been REALLY slow.

 

 

If you launch Spotlight, do you see an indexing bar in the top left below the text field? If it's indexing (or re-indexing, or there's corruption and it's stuck while indexing - keeping in mind Sierra IS still in beta), the OS X metadata index won't necessarily be able to provide complete results. 

 

Cheers,

Vero
Link to post

I just checked, and I don't see the indexing bar in Spotlight. And, as I said, the odd thing is that Spotlight seems to be unaffected. It can find apps with no problem, while in Alfred I have to try 3-4 times before it'll show up.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...