Jump to content

Firefox 48 multi-process: 1Password integration broken


gebu
 Share

Recommended Posts

Hello,

with the new Firefox 48 multi-process the 1Password integration of Alfred is broken (tested with Alfred 3.0.3 on OSX 10.11.6 and 1Password 6.3.1 and Forefox 48 with multi-process enabled (1P add-on version 4.5.8).

The reason for this seems to be the not working 1-Click Bookmarks of 1P within Firefox 48. See also this thread on the 1P-Website.

 

When entering "1p urlname" in Alfred, the browser is opened and the url is entered, but the website does not load and stays white. For a few moments you can see the loading spinner, but nothing happens. The master-login screen of 1Password is not shown. Nothing happens when clicking on the reload-button of Firefox.
 

Link to comment
Share on other sites

Alfred's integration with 1Password is essentially quite simple. Alfred crafts a 1Click URL from the 1Password 3rd party integration data and passes this URL to OS X to open in the default browser. Beyond this, the behaviour of how 1Password processes this URL is outside of Alfred's control... In this case, there isn't much else Alfred can do.

 

Vero will chime in on the thread you linked.

 

Cheers,

Andrew

 

[moving to investigating]

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...