Jump to content
lentaro

Text Formatting Snippets?

Recommended Posts

Hi all! Computer savvy but Aflred-dumb! I can make snippets work BUT is there a way to format the text in the snippet? Can I bold or italic a word?

 

Thanks in advance!

Share this post


Link to post

One exception to this rule is you can change the casing to your most recent clipboard item using snippets

Example:
{clipboard:lowercase}

will turn: HeLLO HoW aRE You?
to: hello how are you?

Note that there are some advanced scripting features you may be able to do using workflows. But I'm not familiar with their capabilities and may require a bit of savvy to setup. 

Share this post


Link to post

@lentaro as @BrianBarr mentioned, there's more way now using the Snippet Trigger. I just sent some workflow in another thread about that, so have a look at this thread and posts to have a way to output Rich Text using a Snippet Trigger. In short, just create a RTF or RTFD file and use it as your snippet.

 

 

Share this post


Link to post
On 12/02/2018 at 5:10 PM, BrianBarr said:

But I'm not familiar with their capabilities and may require a bit of savvy to setup. 

 

With workflows, you can do more or less anything with a snippet because you're using a snippet to call your own code. It's more a question of what's practical, given how much more time & skill implementing snippets via Snippet Triggers can take.

Share this post


Link to post

 

Late to the party, but I think I found a way to use dynamic placeholders and get some basic rich text capability without a RTF file or any AppleScriptObjC kung-foo. For example, I like to add a date stamp if I reply to email inline. By typing \\ctv, I get  [TV 03 Apr 19] or whatever the date is automagically.

 

Achieved it with the flow in the workflow below. I've added a screen shot of what the "Copy to clipboard" includes in it. This works in Pages and this forum. So not thoroughly vetted, but something to work with.

 

The initial problem seemed to be the copy from clipboard would "overwrite" the invisible element initially sent with the key combo, in my case the bold. Adding the space after the key combo seems to make the result more consistent. It may not line up the way you want, but the tradeoff is something working consistently. 

 

Other observations are that even with the {cursor} placeholder giving me a space after the closing bracket, I still need to hit the spacebar before I can manually turn off the bold by hitting the key combo again. This isn't a problem in practice because I'm making a comment and will enter some text anyway (which will also be bolded). I tried adding the key combo again after the "Copy to clipboard", but that really did nothing except make things function inconsistently again.

 

If it helps you, great. If it doesn't, no harm.

 

Screen Shot 2019-04-03 at 21.39.31.png

Screen Shot 2019-04-03 at 21.44.43.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...