Jump to content

search not working correctly


rounak

Recommended Posts

I tried that, and it doesn't work. 

 

I tried long ago to set up a File Filter for ~/Library/Logs. Can search the files just fine in Finder, but Alfred can't "see" most of them, "show system files" or no.

 

I can't recall right now whether mdfind worked or not.

Link to post

 

~/devon-think

added in search scope

 

but folder "database" contained in ~/devon-think is not shown in Alfred.

Reload Aflred cache

No change in result.

 

Checked "Include folders in Home"

"database" folder and its content appear in search

 

Unchecked "Include folders in Home"

results disappear again

 

edit 1: however, there is no change in the behaviour of ~/Libaray/Script Libraries after checking "Include folders in Home"

 

Link to post

@rounak Alfred's cache only applies to applications and preference panes. Reloading it has no effect on other types of files. The "Include folders in Home" says right underneath it "Excluding ~/Library"…

 

The files in ~/Library/Scripts are marked as system files—as Andrew described above. To search them, you need to use a File Filter with the "Show files marked as System Files" option selected. That option doesn't exist for the default scope, so there's no way to get scripts in ~/Library/Scripts in your default results.

 

If you use a lot of AppleScripts, this workflow might be useful. It also knows about application-specific script directories.

 

@Andrew I double checked ~/Library/Logs. mdfind can't see any of the log files in there, either, so I guess they're not actually indexed. Finder lets you search ~/Library/Logs by filename, but not by content.

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...