Jump to content
slayernyte

Snippet Auto Expand Does Not Fully Replace Keyword

Recommended Posts

Auto expand snippets no longer fully replace the snippet place holder with the text in any application. I have noticed this on both my home and work computer. The functionality appeared to stop working after the latest OS update. In the provided screenshot, you can see where the keyword is only partially replaced with the snippet. The orginal keyword was "!arg". In fact, i just experienced the issue as I typed the keyword in this post. 

 

OS X El Capitan version 10.11.6

 

Security___Privacy_and_1__amadigan_LM-_____zsh__and_Alfred_Preferences_and_Bug_Reports_-_Alfred_App_Community_Forum.png

Share this post


Link to post
Share on other sites

This may be caused by one of the other apps in that accessibility list in your screenshot. Would you mind temporarily disabling the other apps in there (unticking them) and seeing if Alfred expands as expected?

 

I also added a "slow down simulated key events" mode from the cog in Alfred's Features > Snippets prefs which can help with this situation. If you update to Alfred 3.2 pre-release, the key events with this mode have been slowed further than 3.1.1.

 

Let me know how you get on :)

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites
On 11/1/2016 at 2:29 AM, Andrew said:

Would you mind popping an email to our info@ address with a bit more info (e.g. Mac spec, any other OS mods you may have), I'd like to get to the bottom of this :)

 

Cheers,

Andrew

Just to clarify, alfredfourm is the domain for the email, correct?

Share this post


Link to post
Share on other sites

×