Jump to content

Problem with workflow running cURL command

Recommended Posts

I'm having problems with this workflow that takes a URL as an argument and then should perform a cURL command. You can download the workflow here


When debugging, this is all I get:

[2016-11-10 09:35:06][input.keyword] Processing output of 'action.terminalcommand' with arg 'chaselivingston.me'

No Terminal window opens as expected to run the cURL command.


After that, Alfred seems to just stop responding, the key combination to invoke Alfred no longer works, and I have to quit Alfred via Activity Monitor to have it start working again.


Currently I'm using Alfred 3.2 Build 759, Tuesday 8th November 2016 and macOS 10.12.2 Beta (16C32f)


Any ideas why this workflow isn't working?

Link to comment

If "UNIX error exception: 17" is happening at the point you try to run, it could be:


If this is the return code from curl:



Received an error when trying to set the transfer mode to binary or ASCII.


If it's from Unix:


SIGUSR2    17    Exit    User Signal 2


Have you tried running simple terminal commands directly in Alfred using the > keyword? e.g. >ls


Have you also tried using a "Run Script" action instead of run terminal command?



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...