Jump to content

Adobe InDesign .indd Documents Not Showing Up In Search Results


Recommended Posts

Greetings Alfred Community,


First, thank you to Andrew and Vero for building and maintaining such a brilliant tool. Alfred is unfailingly the first app I load onto any new personal computer.


I've been experiencing a small but persistent issue for a few months now:


InDesign (.indd) files do not show up in search results.


A few details to contextualize the issue:


  • InDesign the *app* shows up — it is only .indd files that do not appear.
  • All other Adobe filetypes and applications (Illustrator, .ai files, etc.) show up in default results.
  • Other filetypes (PDF, EPS, etc.) in the same folder as an .indd file show up — just not the .indd file itself.


Things I've tried:


  • Updating to the latest versions of Alfred and Adobe.
  • Clearing the Application Cache.
  • Reconfiguring default results to locate .indd files.


What I'm trying to accomplish:


  • Resolve the invisibility of .indd files so I can call them up in Alfred's search bar just like any other file.


Any help you can give is greatly appreciated.


In advance, thank you!


— Justin

Link to comment
12 hours ago, vitor said:

Alfred Preferences → Features → Default Results → Advanced…. Drag and drop an indesign file in that window.


Does that fix it?


@vitor —


Yes! I didn't realize the 'Advanced...' settings in Default Results would yield such an easy fix.


Out of curiosity: Do you (or @Andrew / @Vero) have any insight on why InDesign files (at least on my machine) would be the only filetype from the Adobe CC suite excluded from Alfred search results?


Thank you for your help — I really appreciate it.





Link to comment

@emrys Have you taken a look at the Indexing troubleshooting guide? This includes all the steps that will be suggested to figure out why this file type isn't appearing (whether your search scope includes them, whether Spotlight can find them, etc)




You can also use the Metadata tool to see what kind of metadata is available on those files. Install this and drop one of your InDesign files on it, and paste the results in your reply:




Link to comment
10 hours ago, emrys said:

Out of curiosity: Do you (or @Andrew / @Vero) have any insight on why InDesign files (at least on my machine) would be the only filetype from the Adobe CC suite excluded from Alfred search results?


I’ve left Adobe a few years ago (currently an Affinity user) so I cannot check, but I do recall that last time I used it, .ai and .psd files could be previewed with Quicklook (.ai files only started being previewed on OS X 10.6 — one of my most used Snow Leopard features) while .indd could not. Not that Spotlight and Quicklook have anything to do with each other in that sense, necessarily, but .indd files are indeed lower priority.

That got me thinking that perhaps .indd files are not indexed by Spotlight (hence why Alfred would not be able to find them, as it uses its index). A bit of searching later, it seems like that might indeed be the case. There’s a plugin to make Spotlight index .indd files. It’s five years old (first vesion) so I’m not sure it still works or is needed, but it might give you a clue in the right direction.

Link to comment

@vitor + @Vero —


Thank you both for your replies. 


@vitor — Thanks for the Affinity rec. Can't believe I've never seen it before. Going to check it out. Re: Adobe indexing — I checked Spotlight out of curiosity, and the .indd files seem to be indexed just fine there. Not sure where it gets lost in translation to Alfred.


@Vero — Vitor's solution of dragging and dropping an .indd file into Alfred Preferences → Features → Default Results → Advanced… seems to have worked. Nonetheless, here's the metadata I garnered using the tool you sent:


/Users/Emrys/Dropbox (Pili Group)/Pili Group Team Folder/Philosophy/Kumu Pono.indd

Internal File Metadata

 Display Name: Kumu Pono.indd
    Alt Names: 
    File Type: dyn.ah62d4rv4ge80w5xequ
    Last Used: 2016-11-09 09:39:20 +0000

Raw mdls File Metadata

_kMDItemOwnerUserID            = 501
kMDItemContentCreationDate     = 2015-09-15 09:24:53 +0000
kMDItemContentModificationDate = 2016-11-09 09:39:57 +0000
kMDItemContentType             = "dyn.ah62d4rv4ge80w5xequ"
kMDItemContentTypeTree         = (
kMDItemDateAdded               = 2015-10-17 01:12:20 +0000
kMDItemDisplayName             = "Kumu Pono.indd"
kMDItemFSContentChangeDate     = 2016-11-09 09:39:57 +0000
kMDItemFSCreationDate          = 2015-09-15 09:24:53 +0000
kMDItemFSCreatorCode           = "InDn"
kMDItemFSFinderFlags           = 0
kMDItemFSHasCustomIcon         = (null)
kMDItemFSInvisible             = 0
kMDItemFSIsExtensionHidden     = 0
kMDItemFSIsStationery          = (null)
kMDItemFSLabel                 = 0
kMDItemFSName                  = "Kumu Pono.indd"
kMDItemFSNodeCount             = (null)
kMDItemFSOwnerGroupID          = 20
kMDItemFSOwnerUserID           = 501
kMDItemFSSize                  = 11972608
kMDItemFSTypeCode              = "IDdB"
kMDItemKind                    = "InDesign® CC 2015.0 Document"
kMDItemLastUsedDate            = 2016-11-09 09:39:20 +0000
kMDItemLogicalSize             = 11972608
kMDItemPhysicalSize            = 11972608
kMDItemUseCount                = 3
kMDItemUsedDates               = (
    "2016-11-05 10:00:00 +0000",
    "2016-11-06 10:00:00 +0000",
    "2016-11-08 10:00:00 +0000"


Thank you again to both of you.




Link to comment

@emrys Taking a look at the metadata, you can see the kMDItemContentTypeTree:



kMDItemContentTypeTree         = (


Normally, this list would contain useful information on the file type, making it easy to identify what it is. For example, here's a png image:



kMDItemContentTypeTree         = (


So InDesign files being poorly identified is why they weren't appearing when expected.


As an aside, I would suggest creating a file filter for your InDesign files rather than adding them to your default results, but that's personal preference as I prefer less cluttered default results and much more focused file filters. If that tempts you, here's how you can create a file filter:



Cheers, :)


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...