Samantha

Keyboard malfunction after workflow hotkey in Chrome

6 posts in this topic

Hello,

 

There's a strange keyboard malfunction after opening a webpage in Chrome using a hotkey combination. The numbers on the keyboard and to Alfred among others don't work. It took me a long time to figure out that it was Alfred. To solve keyboard issue, a complete restart is needed. When going directly to the webpage without Alfred hotkey, the keyboard works as usual.

 

This doesn't happen in Safari. Mac Pro and Macbook Pro Sierra 10.12.1

 

Thank you for checking.
 

Edited by Samantha

Share this post


Link to post

@Samantha This could be caused by any number of things (outside of Alfred), but one thing you could try to set the hotkey trigger mode to either pass through or wait for modifiers release (right click on the hotkey field). It may be the combination of simulated modifiers released and something in Chrome which is causing the modifiers to remain stuck.

 

Also, are you on the very latest Alfred 3 release?

 

Let me know how you get on :)

 

Cheers,

Andrew

Share this post


Link to post

I've just had a similar problem in Safari Version 10.0.2 (12602.3.12.0.1) using Alfred v3.2.1(768)

 

I created an Open URL with HotKey workflow and when I invoked it, the URL opened but my keyboard was borked. Looked like the modifier keys were stuck. 

 

Only resolution was a restart. After seeing the information in the previous post, I checked and the default trigger behaviour was "Simulate Modifier Keys Released"/ I changed it to "pass through Modifier keys" and this seems to have cured the issue. 

Share this post


Link to post

Thanks for confirming, @donmc

I am using 3.2.1 on mac 10.12.2

 

Thanks for the suggestion, @Andrew sorry for the late reply.

 

Looks like it's working now in Chrome. I see two action options:

Pass through to workflow and Show alfred

 

 

Thank you!

Edited by Samantha

Share this post


Link to post

@Samantha Could you please launch your System Preferences to Security & Privacy > Privacy > Accessibility, and let us know what other apps are listed in Accessibility? It sounds like another app with Accessibility may be interfering when using hotkeys.

 

Do you have any Chrome plugins? If so, what are they?

 

Could you also provide more details on the hotkey-based workflow you've created (what is it intended to do) and the hotkey(s) that appear to cause the issue? 

 

Cheers,
Vero

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now