Jump to content
anthonymobile

Snippet expansion ignores 'mid-string' flag off

Recommended Posts

Just started using snippets in A3 and love it - much faster than AText which I was using before and have now removed permanently.

 

However, despite turning "Expand snippets mid-string" off and rebooting several times, A3 still insists on expanding mid-string.

 

for instance whenever i try to start tmux i get tomorrowux!

 

Sierra, MBA 11"

 

Any help?

 

 

 

Screen Shot 2016-12-28 at 4.26.42 PM.png

Share this post


Link to post
Share on other sites

There isn't quite enough info for me to see what's going on here... what is your snippet keyword, and the snippet body?

 

I suspect that this isn't the mid string option, you may need to slow down simulated key events in the Tweaking tab.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites
4 hours ago, anthonymobile said:

well, user error as usual.

 

i added a space to the end of my snippet and its working as expected.

 

Alfred seems to work a little different from other text expanders i've used like Atext

 

Yeah, I think you've misinterpreted how Alfred's options work based on how other snippet expanders behave.

 

In Alfred, "expand mid-string" doesn't mean when the trigger terminates mid-string (i.e. without a trailing space/tab/line break etc.), but when it starts mid-string.

 

AFAIK, Alfred never waits for a trailing delimiter (e.g. space/tab/line break etc.) before expanding, which is what other snippet expanders do by default (well, at least the ones I'm familiar with), and thus what many people would assume the "expand mid-string" option means.

Share this post


Link to post
Share on other sites

×