Jump to content
hawkmonitor

1Password integration

Recommended Posts

In Alfred preferences, under 1Password, I have checked “Enable 1Password Bookmarks” and entered a keyword “1p”

In Alfred, I have enabled integration in 1Password by going to “Advanced”.  There I placed checkmarks in “Integrations” - Enable Third Party Integrations, and “Web Browsers” - Verify browser code signature.

I have set up an Alfred hotkey.

After launching the Alfred hotkey and typing 1p BOOKMARKNAME, the bookmark is not recognized, website opened and the 1 Password stored password username entered.

Alfred Hotkey.png

Share this post


Link to post

@hawkmonitor First, when you go to Alfred's Preferences under Features > 1Password, can you see a list of your bookmarks? This should be similar to the fourth screenshot on this page, where you can see three bookmark entries - you'll most likely have many more bookmarks. :)

 

https://www.alfredapp.com/help/features/1password/

 

If you don't see any bookmarks, click "Advanced" in the bottom right, and uncheck/recheck the "Discover Automatically" checkbox, as it's possible that Alfred isn't looking at the correct 1PW file.

 

With regards to the screenshot you provided; This is your primary Alfred hotkey, and has nothing to do with 1Password specifically. I'm not sure Cmd + / is the best choice of hotkey as this is commonly used by other apps. The default hotkey is Alt + space.

 

Let us know how you get on. 

 

Cheers,
Vero

Share this post


Link to post

Thanks Vero.  Very curious!  I have about 250 1Password logins.  When I go to Features.> 1 Password.  There is only 1 1Password login item listed.

Per your advice, Vero, I went to Advanced and unchecked, then checked, and got same result. The entery shown was "/Users/abel/Library/Containers/2BUA8C4S2C.com.agilebits.onepassword-osx-helper/Data/Library/Caches/Metadata/1Password", if that provides any clues.

 

Thanks

 

PS. I have had no conflicts with other software using command 1

Share this post


Link to post

@hawkmonitor Could you please confirm the following:

 

- Which version of 1Password and Alfred you're currently using?

- Are you using multiple 1Password vaults? Or using the Family or Team versions of 1Password?

- Have you used the 1Password beta versions at any point? 

 

Cheers,
Vero

 

 

Share this post


Link to post

No, Vero, to my knowledge I have never used a Beta version of 1Password. Am using the Family Version of 1 Password.  Version 6.5.3 (653001).

The integration with this version worked perfectly until recently.  :(

Share this post


Link to post

@hawkmonitor I also asked which version of Alfred you're using, as this will affect whether you can see your family vault. Can you please confirm which version you're on?

Share this post


Link to post

@hawkmonitor Thanks. Good, you're on the latest version for both, which takes a few variables out of the equation. With your Family edition, are you using a single 1PW vault for all your passwords?

 

Next, could you please go to path you mentioned above? Copy & paste it into Alfred from the "Discover Automatically" pop-up to navigate to it quickly, then press right arrow to choose "Reveal in Finder". How many items are listed in this folder (and any subfolders if you're using more than one vault)?

 

Finally, if you add a new bookmark in 1Password, is it added to the other single 1PW entry you can see in Alfred or not? 

Share this post


Link to post

Am very confused. I open up Alfred/Preferences/1Password, then click “Advanced” in lower right corner.  At that point, on the left sided of the bottom of that screen it says “Loaded 383 bookmarks”. I click “Advanced”.

It opens a window which says “1Password Data, shows a check box which says “Discover automatically”. Beneath that there is the string that I sent you, followed by the warning “Ensure that ‘Enable integration with 3rd party apps” is enabled in 1Password’s Advanced preferences.” I then close the window.

As far as your instructions to “press right arrow to choose “Reveal in Finder”, please give me a clue as to where in Alfred i goto chose this.

The best I am able to answer regarding 1Password is that I believe I have a shared vault.  My wife and I each can access the passwords there.  It may that we each also have separate vaults, but there is hardly any data in these.  Hope this answers your question sufficiently.  If not, please let know and I will get in touch Dave Teare and his Agile Bits team to find out.

I created a new 1 Password login and went to see if it appeared in the Alfred 1 Password list.  IT DID.

Next, I tried Alfred:  1P  Website name, and it worked like a charm.

While happily my problem is solved, I am sending this along in hopes that it will be useful in helping someone else who had this problem.

Hawkmonitor

 

 

Share this post


Link to post

@hawkmonitor If it says "Loaded 383 bookmarks", it's likely that clicking "Discover automatically" at some stage allowed Alfred to view the right bookmarks file. Sounds like you're all sorted now.

 

Cheers,
Vero

Share this post


Link to post

Sorry to be back so soon.  Just installed version 3.3 and integration with 1Password no longer works..  Have checked for 1Password integration in both Alfred and 1Password.  Don't know where to go from here.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...