Jump to content
hawkmonitor

Workflow_ How to activate application menu item

Recommended Posts

Have created a hotkey which opens an application.  Want to add to it an Alfred command which activates a menu item in that application.

Copy of my workflow is attached

Have added to my workflow  a keyboard command which call the shortcut keystrokes for that menu item.  Workflow I created doesn't do that.

What am I doing wrong?  Thanks.

Screen Shot 2017-01-23 at 10.19.50 AM.png

Share this post


Link to post

Hard to know without all the pieces (that’s just s screenshot and I don’t have Quicken), but it might be that the Key Combo is firing too early, thus not being recognised by Quicken since it hasn’t finished launching. Try adding a delay between Quicken and the Key Combo.

Share this post


Link to post

Thanks Vitor.  Could you please be a little more specific.  I don't do know where to put a delay or how it is done.  Sorry, but I am not a programmer. Would that be an Alfred "Action?"

Share this post


Link to post

It’s in Utilities → Delay.

aVc6OjB.png

 

Connect it in between the last two nodes. Start with a big delay (say, 10 seconds) and if it works gradually bring it down until you find the sweet spot (shortest delay that still works reliably).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...