Jump to content
Nikersify

Polyglot - yet another Google Translate workflow

Recommended Posts

@Xusqui

 

I've pushed a version of the workflow that should throw a more verbose error, I'm not really confident that it will help but it's always something.

You can install it by running the following commands:

$ npm rm -g alfred-polyglot
$ npm i -g nikersify/alfred-polyglot#verbose-errors

Looking forward for your report, thanks in advance!

Share this post


Link to post

I've tried...

 

 

It took quite a bit, but it installed:

 

Quote

iMac:~ franciscofernandezcano$ npm i -g nikersify/alfred-polyglot#verbose-errors

 

> alfred-polyglot@1.2.1 postinstall /Users/franciscofernandezcano/.npm-global/lib/node_modules/alfred-polyglot

> alfy-init

 

+ alfred-polyglot@1.2.1

added 148 packages from 59 contributors in 108.356s

iMac:~ franciscofernandezcano$

 

Now, instead, I have a forbidden 403 error...

 

Your script doesn't like my computer :D

Share this post


Link to post

Hey again @Xusqui,

 

Pushed yet another version with a potential fix for the 403 error as described here, mind trying that one out?

$ npm rm -g alfred-polyglot
$ npm i -g nikersify/alfred-polyglot#client-gtk

Hope the workflow likes your computer this time 😄

Share this post


Link to post

It's very weird!!!

 

I Installed the new version... AND IT WORKED... for a couple of times... After that, I get again the same error...1083492725_Capturadepantalla2018-12-06alas6_43_27.thumb.jpg.0a2cf7f9443d3559e76403eb897fb6c7.jpg

 

I uninstalled and installed again but no way...

 

Thank you very very much!

 

--- EDITED ---

 

FYI I've tried tons of translators workflows (even one installed also via npm [can't remember the name, but something like ultimate-google-translator or something like that]), and none has ever worked out... This morning I tried this simple one and is the only one that has worked on my computer.

Edited by Xusqui
Add info

Share this post


Link to post

Thank you very much indeed.

 

Anyway I'll have an eye on this and will give a new try whenever you release a new version!

 

congrats for your work!

Share this post


Link to post

@Nikersify I have exactly the same symptoms as @Xusqui. After I've uninstalled the workflow and updated to this version

Quote

$ npm rm -g alfred-polyglot
$ npm i -g nikersify/alfred-polyglot#client-gtk

 

it worked for a single translation. The next was the same as the ones before – I'm back with errors  105:17 and 68:7. 

Just so you know @Xusqui is not the only one. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×