Jump to content

Issue with run / external script - no output


Recommended Posts

Hi folks,

 

I am writing a workflow to defang URLs. I use the following binary:

 

https://github.com/jakewarren/defang

 

I added this binary to the workflow folder, +x it and created Run / External Script (tried both approaches). I get no output when running the binary using the workflow. Binary works fine in the terminal though. I am not posting screenshot of broken workflow as requested.

 

The workflow can be downloaded from here: https://we.tl/t-De7Zu5H3S5

 

I have tried different approaches: external script, run script, with argv and query. Hope to find some help in this forum :)

 

Thank you!

Link to comment

Hi @irish_sonas, welcome to the forum.

 

Thanks for the excellent description. It makes it really easy to try to help you.

 

58 minutes ago, irish_sonas said:

I have tried different approaches: external script, run script, with argv and query.

 

It's due to defang's weird input handling that behaves differently when it's not run in an interactive shell. I'd report a bug.

 

In the meantime, this bash script works in Alfred echo "$1" | ./defang_1.0.9

 

You also don’t need the Copy to Clipboard because defang always puts the new URL on the clipboard, which is also a bit of a weird thing to do.

Edited by deanishe
Link to comment

Wow, thanks @deanishe for such a quick response and the working solution.

 

It is indeed strange that defang automatically interacts with clipboard. The input method handling is also of concern... perhaps I would need to research another library / binary to use.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...