Jump to content

Alfred v4 workflow stopped working - always goes to fallback search now


Recommended Posts

Hey there, I'm a day one mega supporter and never had any problems so far. It just worked.

Now after a recent computer change and upgrading to Monterey, a (very basic) workflow no longer functions.

 

I used a template from Files and Apps called "file filter from keyword and open" - search scope is a Dropbox subfolder.

 

Until now it allowed me to search inside the subfolder and open a file. Now, when I type the keyword (fl), it shows the filter's name (Freelance) - I hit space, everything still looks fine, but as soon as I enter any query, it changes to "search google for 'fl <query>'".

I've recreated the workflow, still won't work.

 

Can somebody please help?

Link to comment

@Thomas8677 Welcome to the forum :)

 

Did you by any chance migrate your data from a previous Mac? If so, you're encountering a known issue with the macOS Monterey Migration Assistant. The issue and workaround are outlined here:
https://www.alfredapp.com/help/troubleshooting/indexing/monterey/

 

Let me know how you get on after following step 2 and widening your search scope.

 

If the issue persists, try using the File Troubleshooter to see whether any metadata is missing for the files you can't find.

 

If you need further help, could you please:
- Provide your Diagnostics file, which you can get by typing "?diagnostics" into Alfred (you can email this to our info@ address with reference to this thread)
- Include the output from a few File Troubleshooting tests for files
- Let me know exactly what you're typing into Alfred when searching for these files (including any keywords or prefixes)

 

Edited to add: It also occurred to me that Dropbox could be playing a part in this issue. Are you using Dropbox's Smart Sync feature, which selectively stores some of your data online-only and downloads it when needed? Please make sure that the files you want to search are stored locally on your Mac, not just online.

 

Link to comment

Hello Vero,

 

first of all, thanks for your help. but I've already advanced a couple of steps further and now created even more problems 😄

 

I tried the Monterey-related scope changes (found those before you posted and extended the scope to "/"), but that did not help me with my issue.

So then I started a deep reindex via sudo mdutil -i on /.

 

After waiting for an hour or so, certain applications (like VNC viewer) are not being found anymore and the workflow still does not find anything either.

 

Example: When I type vnc -> I only get the "search google for vnc", but when I type /Applications/vnc -> it shows VNC viewer ... so I guess it is still indexing? Alfred's troubleshooting file thing shows me VNC viewer is indexed, though.


I sent the diagnostics file and a troubleshoot output for VNC viewer.

 

Thank you.


 

Link to comment

Ok, quick update. I've started reindexing and checked Spotlight to see the progress. It took more than 2 hours (on a MBP Pro M1 with 16GB) - the indexing is now finished.
But not a single Application appears in Alfred's search, although the troubleshooting check says "  Troubleshooting passed".

I tried resetting the scope and extending it again, but nothing worked. I'm out of ideas at this point.

Link to comment
Posted (edited)

Ideas anyone? 

 

After reindexing Alfred is now pretty much useless. It shows no applications at all, I've been using it for 11 years and feel pretty much lost without it.

File Search Troubleshooting gives me green checkmarks on all applications I drop on (Spotify, Sublime, Brave Browser, etc.)

 

I really need help, my workflow centers around Alfred as a launcher. I know, that I can hit F4 and search in Launchpad, but I don't like it 😊

Edited by Thomas8677
Link to comment

Ok, more weird things are happening. 

 

I just tried spotlight ... it found spotify.app when I entered "spo" - but only one time. On consecutive search also spotlight stopped showing apps altogether.

I see, why the problem is probably the access to the index database (as stated before: file search troubleshoot reports all is well), but I don't have any peculiarities in the spotlight preference pane (all types checked, no folders excluded)

Link to comment

@Thomas8677 Taking a look at your Diagnostics, you're using quite an old version of macOS Monterey; When using a new version of macOS, it's essential to keep up with the updates, so first please update macOS.

 

Once you've updated and restarted your Mac, the first baseline to check is whether Apple's own Spotlight finds your apps. If it does not, then there's an underlying indexing issue outside of Alfred. You can try reindexing your Mac and if this fails, you can contact Apple for support.

 

Once you have confidence that apps are being found in macOS itself, we can then take a further look at whether apps are found or not in Alfred.

 

Let me know how you get on.

 

Cheers,
Vero

 

Link to comment

Hi Vero,

 

as stated above - reindexing and widening of search scope did not help at first (nor did adding a second user and then deleting it again which another thread suggested).

 

It is crucial, though, to actually restart your mac after rebuilding the index was finished. Once I rebooted, everything turned back to normal, even my file search workflow started working again. Thanks for the help, sorry for the fuzz.

Not 100% sure, what steps where actually necessary to fix the issue, but don't forget a final reboot  🙂

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...