Jump to content

Snippet expands but browser doesn't open the page

Recommended Posts

Hi. I used to be able to have a snippet open Brave browser settings



Now when I type in a snippet a get a popup that says "There is no application set to open the URL brave://settings."


The snippet used to work before I switched Safari. Brave is once again my default browser in System Preferences. To remedy this I tried to clear the app cache and rebuilt the macOS metadata in Alfred however I'm still getting the same error. 


Any advice what I can do to fix this? Thanks?

Screen Shot 2022-06-24 at 9.09.46 AM.png

Link to comment
On 6/25/2022 at 1:09 PM, vitor said:

To force that URL to always open in Brave, use a Run Script with default settings and code:


open -a 'Brave Browser' 'brave://settings'



I'm not familiar with coding. I've tried out different variants in the run script but they aren't taking me to Brave browser settings. This is what the workflow looks like. Am I doing something wrong or is there something else I should be doing? Thanks.


[15:46:36.236] Open Brave:Settings[Keyword] Processing complete
[15:46:36.237] Open Brave:Settings[Keyword] Passing output '' to Run Script
[15:46:36.257] ERROR: Open Brave:Settings[Run Script] The file /Users/Local - Documents/App Preferences & Exports/Alfred - Preferences/Alfred.alfredpreferences/workflows/user.workflow.79F2AE61-81EB-43A5-A912-BB8072114948/brave:/settings does not exist.

Screen Shot 2022-06-26 at 3.46.33 PM.png

Screen Shot 2022-06-26 at 3.38.05 PM.png

Link to comment

Oh and as a side note I noticed when I type "@bb1" into Alfred I get a search result for "Display text in Large Type." I've searched my workflows and I don't have anything like that installed. Any idea why that is populating below the brave:settings search result?

Link to comment
1 hour ago, vitor said:

Here’s a correctly configured Workflow.

I was looking for a snippet or a keyword as the input function because I've several snippets I use within Brave. I've tested all three and only the keyboard shortcut seems to be recognized as an error. Snippet or keyword functions aren't populating in the debugger. 


[17:18:58.248] Open Brave Settings[Hotkey] Processing complete
[17:18:58.253] Open Brave Settings[Hotkey] Passing output '' to Run Script
[17:18:58.328] ERROR: Open Brave Settings[Run Script] The file /Users/Local - Documents/App Preferences & Exports/Alfred - Preferences/Alfred.alfredpreferences/workflows/user.workflow.FAD4B565-714B-4398-8F32-56DDD3B07D20/brave:settings does not exist.

Screen Shot 2022-06-26 at 5.06.59 PM.png

Screen Shot 2022-06-26 at 5.17.27 PM.png

Link to comment

Something is borked in your setup. Either on macOS or Brave, something isn’t working as it should. You’ll have to figure out what it is. Think back to what you’ve done/installed/uninstalled at the time it stopped working.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...