Jump to content

Workflow Error: 'launch path not accessible'

Recommended Posts

I saw a similar question about this, however, that was resolved via dependency issues.  And at this point, I don't seem to have that problem that I can tell ...


I have a workflow, which has run in the past, but not since updating to Sonoma.


Debug output:

[09:13:34.934] Workflow[Script Filter] Queuing argument '(null)'
[09:13:34.944] Workflow[Script Filter] Script with argv '' finished
[09:13:34.951] ERROR: Workflow[Script Filter] Code -1: Task '/Users/ashfordp/Documents/Alfred5/Alfred.alfredpreferences/workflows/user.workflow.473C055E-E863-4FBF-A054-D91C56DBD378/status.py' failed with reason 'launch path not accessible'


If it was a dependency issue, I would expect that I cannot run that status.py script from the terminal, but I can.    The script env is:


#!/usr/bin/env python3


which is installed in /usr/local/bin/python3, so I am able to execute that script.


My only other guess is that when Alfred is executing the script, /usr/local/bin is not on the path maybe??  The script is in a Script Filter Input, marked as an "external script".


Any thoughts/helpful hints would be appreciated.






Alfred: 5.1.4

MacOS: 14.1.1

Link to comment
3 hours ago, arougthopher said:

which has run in the past, but not since updating to Sonoma.


Then the likeliest explanation is that your Developer Tools broke, which happens occasionally when macOS updates. Open a terminal and run xcode-select --install.


Another option is that you’re syncing your preferences but they’re not available offline.


If neither the case, please share the workflow in question. We don’t even know its name so it’s impossible to properly investigate what may be wrong.


3 hours ago, arougthopher said:

My only other guess is that when Alfred is executing the script, /usr/local/bin is not on the path maybe?


It is.

Link to comment

Thanks for the quick reply.  The workflow was developed internally at my company.  It is a script to automate the connection to Cisco VPN.


I already thought about the offline issue too ... I tried moving my Preferences folder out of my shared directory into my Documents folder on my local drive, and restarted it (can see in the log output earlier).


So, I just fixed the workflow ... both the Script Filter Action and another Run Script action had Language set to "external script".  Changed it to Python3, and just pasted the script directly into the text field, instead of referencing the script file in the preferences directory, and it works.  


I will try to create a new simple sample workflow, using the External Script option, and see if it happens again.

Link to comment

tried, but was unable to reproduce.  worked on a new script.  only difference I can tell is that the permissions of the file I created in the new workflow were 




but the script that didn't work had




but, that shouldn't cause a problem.  If I can reproduce, I will submit a bug.

Link to comment
  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...