Jump to content

File search issue

Recommended Posts

Hello everybody,


in alfred preferences, setting file access to all disk works fine, As soon as we try narrowing the scope, it doesn't work anymore: Alfred couldn't find any file.


Just to give more info:

1. my macos is up to date (sonona 14.4.1)

2. I just installed Alfred

3. I tried to reinstal it

4. I ran the troubleshooter, which told me to reset scope to full disk, but I don't want Alfred to include files from the whole disk

5. We have tried different types of file, so the problem is not about file types to include or not in search results. This is not an indexing issue either, because everything works as intended as soon as the scope is reset to full disk


Thanks for your help !

Link to comment
Posted (edited)

I'm having the exact same issue. In my case, I've upgraded two different computers from older operating systems to Sonoma (LONG time user!), and the issue happens in both.


I've run the troubleshooter and it suggested resetting scope to the full disk. If I do this, I can find the files just fine.


I can see more people with the issue:


Edited by stormymondays
Link to comment
Posted (edited)


10 hours ago, Stephen_C said:

Welcome to the forum.


The best suggestion is to work slowly and carefully through all  of the suggestions on this Alfred help page: Troubleshooting File Indexing Issues. I mention that only because it's not clear from your post that you have done that…so apologies if you have.



Thank you. I did not tick spotlight's boxes. The issue is now resolved. Hope that helps!

Screenshot 2024-05-14 at 09.09.39.png

Edited by brunoleb
Link to comment
Posted (edited)
3 hours ago, Stephen_C said:

have you, as I suggested in this post, worked through all of the suggestions on the Alfred help page to which that post linked?


I've gone till Step 5 (plus 7 and 8). I'm now going to delete the Spotlight folder. Alfred is finding files when the scope is set to the full drive, so I have my doubts this will fix it. I'll report back after the indexing has finished again.


EDIT: I'm eating my words (and the proverbial hat!!!) - deleting the Spotlight folder fixed the issues!


Edited by stormymondays
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...