Jump to content

Yosemite Spotlight Server is Disabled

Recommended Posts

Although this is not an Alfred bug, Alfred relies on the spotlight server (I believe) to index so I am not getting any indexed results.


I am not sure how I managed it (although I think it might be because I had spotlight disabled before upgrading to yosemite), but my spotlight server seems to be disabled. Trying any mdutil commands result in:


-07 08:55:25.673 mdutil[2360:239343] Metadata.framework [Error]: mdsCopyStorePaths failed: (268435459) (ipc/send) invalid destination port

Spotlight server is disabled.


All of the forums out there that have instructions to stop and start spotlight seem to reference plist service files in /System/Library/LaunchDaemons that do not exist in yosemite :-(

Link to comment

Hi there, I have exactly the same problem as ronnie.barker. !


I have only just udapted to Yosemite (10.10).

Before, I had turned spotlight off for ages because it slowed my time machine backup down.

Now I just wanted to test it and turn it on again, because the search in Mac Mail.app doesn't work - and I would need the search there now.


I tried the command


sudo mdutil -a -i off (and on)


and it came up with: 

mdutil[1766:78805] Metadata.framework [Error]: mdsCopyStorePaths failed: (268435459) (ipc/send) invalid destination port

Spotlight server is disabled.



After that I tried the command Rodger also recommended (sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist) 

and Terminal did not seem to react, the Spotlight Search still does not work or show that it is indexing - how can you check that it actually does?


After that I tried the command again and now it says: 

/System/Library/LaunchDaemons/com.apple.metadata.mds.plist: Operation already in progress


Does that mean it is indexing now? How do I know how long it will take?


Thanks a lot for any help in advance!

Link to comment

just to let anyone know who is interested.. I have rebooted after trying the above and typed in the commands


sudo mdutil -i off /

sudo rm -rf /.Spotlight*
sudo mdutil -i on /


 after each other.


Now spotlight works and is indexing! will turn it off before the next time machine back up though ;)

Link to comment
  • 6 months later...

I'm struggling to make Alfred search (only) in a network shared folder in Yosemite.

Sometimes Alfred works and sometime no (from client).

The odd is that ONLY Alfred search from client on server (shared folder).

Spotlight on client not search on server.


You've executed this command on server or on client ?

I've tried on client all these commands, with no improvements ...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...