Jump to content

Use mailto: for webmail


ThisIsXO
 Share

Recommended Posts

In the settings there's an option to use "webmail" but it only works with gmail, if alfred launched a new tab/window with mailto: then whatever site you've got setup to use that handler would open. For example, yahoo mail, hotmail, etc.

 

Also when you select use webmail the icon changes as soon as you type an email address.

 

QZGrYy3.pnghXLdnQv.png

Link to comment
Share on other sites

  • 8 months later...

Yes, this (or similar) would be quite wonderful! There's currently no way for me to integrate non-Gmail webmail providers with Safari as my default browser.

 

Ideally, next to the "webmail" checkbox in Alfred prefs, there would be a little dropdown menu with "gmail, hotmail, yahoo, fastmail, custom..." as options... which covers the most popular and would still allow for other providers.

 

Currently, this is not an issue with Google Chrome, which allows you to set the mailto: handler to anything you want. However, I use the Fastmail web interface in Safari, and while there is a Safari extension to catch mailto links and redirect them to Fastmail, this does not work for clicks generated in other apps. For example, in Alfred with the "webmail" box unchecked, clicking on a contact's email will open a Mail.app compose window, even if Safari is set as the default mail handler in Mail.app preferences. With the "webmail" box checked, Safari handles it correctly, but loads Gmail (which I don't use).

 

In the settings there's an option to use "webmail" but it only works with gmail, if alfred launched a new tab/window with mailto: then whatever site you've got setup to use that handler would open. For example, yahoo mail, hotmail, etc.

 

Also when you select use webmail the icon changes as soon as you type an email address.

 

QZGrYy3.pnghXLdnQv.png

Link to comment
Share on other sites

For example, in Alfred with the "webmail" box unchecked, clicking on a contact's email will open a Mail.app compose window, even if Safari is set as the default mail handler in Mail.app preferences. With the "webmail" box checked, Safari handles it correctly, but loads Gmail (which I don't use).

 

 

That's because, unlike Chrome, Safari can't actually handle mailto: links and just opens your email program instead. Seeing as you've set your email program to Safari, and Safari doesn't actually do email, it opens Mail.app instead.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...