Jump to content

Alfred v2 can't remember prefernces modification [Fixed b178]


lululau
 Share

Recommended Posts

version: v2.0.1(173)

 

OS: 10.8.3

 

it can not remeber the prefernces modifications haven been done after restarting the Alfred app, e.g. "Appearance -> Options -> Hide hat on Alfred window", "Features -> Default Results -> Search all file types", etc.

Link to comment
Share on other sites

version: v2.0.1(173)

 

OS: 10.8.3

 

it can not remeber the prefernces modifications haven been done after restarting the Alfred app, e.g. "Appearance -> Options -> Hide hat on Alfred window", "Features -> Default Results -> Search all file types", etc.

 

There could be a permissions problem on your Mac which is preventing Alfred from persisting the preferences. The first thing to do is quit Alfred and then repair your OS X disk permissions in Disk Utility.app. Then restart your Mac and restart Alfred to see if this helps :)

Link to comment
Share on other sites

There could be a permissions problem on your Mac which is preventing Alfred from persisting the preferences. The first thing to do is quit Alfred and then repair your OS X disk permissions in Disk Utility.app. Then restart your Mac and restart Alfred to see if this helps :)

 

I cleaned up the "~/Library/Application Support/*[Aa]lfred*" folders and the "~/Library/Preferences/*[Aa]lfred*" files, but that did not work, is there any files/folders should be cleaned up which could fix this problem other than doing FS permission repair? 

Link to comment
Share on other sites

I cleaned up the "~/Library/Application Support/*[Aa]lfred*" folders and the "~/Library/Preferences/*[Aa]lfred*" files, but that did not work, is there any files/folders should be cleaned up which could fix this problem other than doing FS permission repair? 

 

 

Take a look at this help article which Vero just put together:

 

http://support.alfredapp.com/kb:persisting-preferences

Link to comment
Share on other sites

Take a look at this help article which Vero just put together:

 

http://support.alfredapp.com/kb:persisting-preferences

 

I created a new user account, and login with the new account then open Alfred and did some preference settings, and the issue still exists. In fact I found that the 'Alfred Preferences' application did persist preferecens I've changed out to the "~/Library/Application Support/Alfred 2/*/*.plist" files, but after relauch the option checkboxes on the 'Alfred Preferences' application panels still keep the original default values.

 

Link to comment
Share on other sites

On this new user profile (where syncing wouldn't have been setup), could you zip up and send me all the files listed in step 3 of that guide... info@alfredapp com

 

Also do you have any unusual setup for your user folder, like symlinking or separate drive etc.

 

Cheers,

Andrew

Link to comment
Share on other sites

On this new user profile (where syncing wouldn't have been setup), could you zip up and send me all the files listed in step 3 of that guide... info@alfredapp com

 

Also do you have any unusual setup for your user folder, like symlinking or separate drive etc.

 

Cheers,

Andrew

 

My users folder is on a separate drive:

 

 

liuxiang@MacBookPro: ~ $ ls -ld /Users
lrwxr-xr-x  1 root  admin  14  1  7  2012 /Users -> /Volumes/Users
liuxiang@MacBookPro: ~ $ df -h
Filesystem                          Size   Used  Avail Capacity   iused    ifree %iused  Mounted on
/dev/disk0s2                       111Gi   89Gi   21Gi    81%  23518313  5576989   81%   /
devfs                              212Ki  212Ki    0Bi   100%       735        0  100%   /dev
/dev/disk1s2                       698Gi  329Gi  369Gi    48%  86267112 96666630   47%   /Volumes/Users
map -hosts                           0Bi    0Bi    0Bi   100%         0        0  100%   /net
map auto_home                        0Bi    0Bi    0Bi   100%         0        0  100%   /home
localhost:/dSPQgoZBXnkoyM_JjHTPfp  111Gi  111Gi    0Bi   100%         0        0  100%   /Volumes/MobileBackups
/dev/disk2s1                       466Gi  394Gi   71Gi    85% 103372370 18716075   85%   /Volumes/MyPassport
Link to comment
Share on other sites

User folder on a separate drive should be absolutely fine - is the Alfred.alfredpreferences being created correctly in the Application Support/Alfred 2 folder?

 

 

 ~  $ ls -ld ~/Library/Application\ Support/Alfred\ 2/Alfred.alfredpreferences/
drwxr-xr-x  6 liuxiang  staff  204  3 17 17:01 /Users/liuxiang/Library/Application Support/Alfred 2/Alfred.alfredpreferences/
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...