Jump to content
Kendrick Liu

[SOLVED] One of my workflows does not work on my Macbook

Recommended Posts

Hi, 

 

One of my workflows does not work anymore on my Macbook after restoring the Macbook from the Time Machine.

Actually the workflow is to connect airpods to the system.

It runs a script and tells system to click bluetooth item on menu bar. 

The workflow and alfred preferences are saved on the iCloud.

The exactly same workflow on my another Mac works perfectly, and it worked on my Macbook before I restoring it.

I've already re-install Alfred but that does not work.

Do you have any ideas?

Thanks a lot.

 

Share this post


Link to post

Welcome @Kendrick Liu,

 

When asking for help with a Workflow, please upload it somewhere as we can’t properly help you without access to it. Debugging can already be hard with access to the code, and you’re asking us to guess yours from a description. There are multiple places where your code or Workflow setup may be going wrong. Without looking at it we’re shooting in the dark.

 

Also, please give us your Alfred and macOS version.


Read the Reporting Problems with Workflows topic, as it gives a nice overview on how to build an effective report.

Share this post


Link to post

Start by replacing the NSAppleScript with a Run Script with /usr/bin/osascript (AS) as the Language.


Then, what exactly do you mean by “doesn’t work”? Where does it fail? Does it fail to even click the bluetooth icon, or is it somewhere else? Open the debugger and set the log output to “All Information”. What messages appears when you try to run the Workflow?

Share this post


Link to post

Hi, after trying, I've found out why this workflow does not run.

The Accessibility in Privacy Setting for Alfred was not granted.

I think it was disable after restoring my macOS.

After granting it, this workflow works fine like before.

Thank you for your support.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×