Jump to content

Play Music not Play iTunes


adamprocter
 Share

Recommended Posts

  • 3 weeks later...

Not sure if this is the same issue or a slightly different one, but it appears the Workflow template hotkey shortcuts are all still configured for iTunes rather than Music and are no longer functional. I used these heavily and daily prior to Catalina and iTunes->Music and would love to see them return. Screenshot of workflow settings in question: 

2020-01-09_11-49-07.png

 

Link to comment
Share on other sites

@dontworrybehappy Perfect, thanks for that! :)

 

While those items are labelled iTunes, they should still work as expected in Catalina. Could you check Alfred has automation allowed (ticked) for Music in the macOS Preferences > Security & Privacy > Privacy > Automation? If it is, perhaps try unticking and re-ticking, then restart Alfred.

 

I've just done a small change in the latest 4.0.8 b1134 pre-release to update the labels to Music if using Catalina.

 

Cheers,

Andrew

Link to comment
Share on other sites

@Andrew Home run for you! That's exactly what it was. That setting was off and toggling it did the trick. I have a theory that when I moved from Alfred 3 to Alfred 4 recently, I probably hit Deny on a few of the installation prompts asking for additional permissions and one of them could have been for the Automation setting in question. In any event, thank you Andrew!

Link to comment
Share on other sites

  • 3 months later...

4.0.9 - Still said iTunes in my Play Pause workflow for me so I removed and rebuilt workflow but now is blank text and so added in my own title ?

However I dont know if this was the behaviour before but if I dont have music app launched and have previously played something.

Triggering to Play launches Music but doesnt start playing anything, you have to go into Music find something to play and then the trigger will work, I thought before it started playing something such as Favorites mix ?

 

FYI there is a number of references to iTunes in the UI of Prefs

Screenshot 2020-05-06 at 11.06.51.png

Screenshot 2020-05-06 at 11.01.07.png

Link to comment
Share on other sites

@adamprocter In the screenshot you provide, you have those keywords disabled in Alfred's default results (the very bottom checkbox)... so the missing text will just be in your own Workflow.

 

You could disable your workflow, and tick the "Show these keywords in Alfred Default Results" to see Alfred's default iTunes / Music keywords.

 

I'll fix the iTunes reference :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...