Jump to content

Command+Shift+Space error


arhoads76
 Share

Recommended Posts

When I assign Cmd+Space to Alfred v2, the system level hotkey Cmd+Shift+Space no longer works.  It appears the Alfred is eating the Cmd key up event.  This causes other odd keyboard manifestations in Parallels regarding Cmd.

 

Again, this worked perfectly in Alfred v1, but does not work in Alfred v2.

 

Link to comment
Share on other sites

When I assign Cmd+Space to Alfred v2, the system level hotkey Cmd+Shift+Space no longer works.  It appears the Alfred is eating the Cmd key up event.  This causes other odd keyboard manifestations in Parallels regarding Cmd.

 

Again, this worked perfectly in Alfred v1, but does not work in Alfred v2.

 

Alfred registers hotkeys (by mod / key ids) with OS X and he is called back when these are pressed, so he doesn't intercept or consume any events. I have managed to create a workflow with the two hotkeys you suggest and both are treated independently.

 

hotkey%20events.png

 

Do you have Alfred v1 running, or two instances of v2 running? (check in Activity Monitor).

 

If not, there may be something else installed which is interfering with this.

Link to comment
Share on other sites

It isn't two workflows that causes the issue.  It is when Alfred itself is activated by Command+Space, and in the case of this example a workflow or other system hotkey is assigned Command+Shift+Space.

 

I've set my Alfred default hotkey to cmd+space, and created a workflow which is cmd+shift+space which posts a notification. Both work as expected where cmd+space shows Alfred, and cmd+shift+space shows the notification I've setup in the workflow (without Alfred showing).

Link to comment
Share on other sites

It isn't two workflows that causes the issue.  It is when Alfred itself is activated by Command+Space, and in the case of this example a workflow or other system hotkey is assigned Command+Shift+Space.

 

I've gone one step further and assigned cmd+space to Alfred v2 and cmd+shift+space to Alfred v1. They show correctly with their respective hotkeys, so Alfred v2 isn't stopping Alfred v1 from showing by having the hotkey set as cmd+space.

 

Architecturally, OS X actually allows multiple things to be assigned to the same hotkey (Alfred naturally prevents this for your sanity), so even if Alfred did try to consume the cmd key, OS X would separately issue out the event to the other app registering the same combo. This is [undesirably] manifested in some cases when people haven't switched off OS X's default keyboard layout switcher with the cmd+space hotkey and have Alfred also set to cmd+space. Both Alfred shows and the keyboard switches layout.

Link to comment
Share on other sites

I can't think of what other things I can kill from my system tray.  I have killed everything I see but Alfred.  I will see if there are any other apps interfering.

 

It might be worth temporarily creating a new user account on your Mac, switching to that (as a fresh profile) and trying from there... don't forget to disable Spotlight from using cmd+space first!

Link to comment
Share on other sites

I closed all of my programs.  Turned off access for assistive devices.  Double-checked all of the hotkeys.  Couldn't find any conflicts and the trouble persisted.  I went back through my workflows in Alfred v2 and found one that I thought was bound to a different hotkey was in fact using Command+Shift+Space.  I bound that to the hotkey I expected for it, and my problem went away.

 

My playing with the new workflows caused my problem, and I didn't see it because I thought I knew what all of those hotkeys were.

 

Thank-you for your patience in helping me.

Link to comment
Share on other sites

I closed all of my programs.  Turned off access for assistive devices.  Double-checked all of the hotkeys.  Couldn't find any conflicts and the trouble persisted.  I went back through my workflows in Alfred v2 and found one that I thought was bound to a different hotkey was in fact using Command+Shift+Space.  I bound that to the hotkey I expected for it, and my problem went away.

 

My playing with the new workflows caused my problem, and I didn't see it because I thought I knew what all of those hotkeys were.

 

Thank-you for your patience in helping me.

 

No worries at all, I am going to make it much easier in the future to get an overview of hotkeys used :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...