Jump to content

Alfred shell workflow cannot find terminal command that used to work and exists on host OS

Recommended Posts

Hi there,


I have been using a workflow that runs a script on my machine for about 6 months now. When using it today it no longer works.


When checking the debug info alfred reports that this command cannot be found. The program does exist on my machine however and works of course when I run the script via a command line shell.


I have the script using /bin/bash as the 'language', but have also tried switching to /bin/zsh to no avail.


The command it cannot find is gshuf.


Alfred version: 4.1.1 [1172]

MacOS: 10.15.7


Not sure if this started happening after a version change to either of these versions, Alfred or the OS respectively.



Link to comment
5 hours ago, trillionanswers said:

The program does exist on my machine


Where is the program? If it isn't in /bin or /usr/bin, it's expected that it won't work in Alfred.


If it’s in another directory, call the program by its full path, not just its name, e.g. /usr/local/bin/gshuf.

Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...