Jump to content

Alfred ignores the setting of Terminal


ImKaiDu
 Share

Recommended Posts


MacOS Catalina and this is the setting of Terminal -> Startup -> Run command: source ~/.bash_profile

When I start Alfred but type in '> ls', it works, such as '% source ~/.bash_profile'.

However, when I start it again, it does works. It sounds like Alfred start Terminal without its setting. 

Any way, I can force Alfred to use the setting of Terminal (Terminal -> Startup -> Run command: source ~/.bash_profile) Or, 'source ~/.bash_Profile'??

Thank you a lot and regards,

Kai

Link to comment
Share on other sites

@ImKaiDu Catalina uses zsh by default, so if you aren't specifically using bash in Terminal, you should move the relevant contents of ~/.bash_profile into ~/.zshrc and this would be included automatically when Terminal starts without having to source the bash profile.

 

Further to this, what you describe sounds more like a Terminal configuration issue. Alfred does give a little further control of the > command in the Features > Terminal preferences. If you select the terminal type of Custom, you have full control over how Terminal launches, and can perform any commands before the typed command is used.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...