Jump to content

alfred:ignore no longer working?


luckman212

Recommended Posts

Hi,

 

  • macOS Monterey 12.0.1
  • Alfred 4.6.1 [1272]

 

I have a problem with some apps like Adobe that litter the disk with dozens of useless "apps", cluttering my search results. If I type "creative" in Alfred for example, here's what it looks like:

 

screen.thumb.png.d1fe64ae63415b65302daf6e1924f951.png

 

I'm trying to hide everything there except "Creative Cloud.app". The simplest way I know of is to add "alfred:ignore" to the Finder comments. This has worked for me in the past, but does not seem to work here.

 

11081475_screen1.thumb.png.5f0b62186a3999806a7fab2662f21e44.png

 

I've tried:

  • quitting/relaunching Alfred
  • using the "reload" keyword
  • clicking the "Clear Application Cache" button in Settings > Advanced

 

I know about adding the folder to Spotlight's ignore list, but I'd like to know why the alfred:ignore method isn't working. Any tips?

 

Link to comment

@luckman212 I've just tested this on Monterey, setting a comment of alfred:ignore on an app and using the "reload"  keyword, and it worked fine.

 

Are the actual Adobe apps in /Applications/Utilities/ or are they somewhere else on your disk? 

 

Moving out of bugs, as it doesn't appear to be a bug, and other Adobe Creative Cloud users may have suggestions on this.

 

Cheers,
Vero

Link to comment

Thanks @Vero for looking at it. Yes these particular apps are in /Applications/Utilities/xxx and in actuality the "real" path may be /System/Volumes/Data/Applications/Utilities/xxx because of APFS obfuscation. Regardless, the "alfred:ignore" trick DOES work for me on files in /Applications proper. Just not this Utilities subfolder for some odd reason. That's the mysterious part, and why I thought it might belong in /Bugs.

Edited by luckman212
Link to comment

@luckman212 Can I confirm that if you use alfred:ignore on a native app, then type "reload", the app disappears from results? The issue is exclusively with Adobe apps?

 

If you use Alfred's File troubleshooting tool to take a look at the metadata of an app after you've added the alfred:ignore, is it correctly showing in the metadata? In much older versions of macOS, I recall that macOS sometimes failed to "stick" comments when they were added. I haven't personally experienced this on Big Sur or Monterey, but that could be what's happening to you.

 

Honestly, Adobe apps have never behaved like normal Mac apps; they may not even be proper apps on your drive as they're part of the Creative Cloud, so you may have to add them to Spotlight's Privacy tab, and create a workflow with keywords > Open File for the ones you do want to see in your Alfred results.

Link to comment

@Vero Thanks for you help on this. I eventually tracked this down to what appears to be a macOS bug. I was setting the Finder comment (and they were appearing in the Get Info box, as shown in my earlier screenshots!) but somehow, the metadata was not actually being populated. Your tip on using the Alfred Metadata Tool was really helpful in identifying this. I ended up using osxmetadata to set the comment (combined with sudo), and that seemed to work.

 

sudo osxmetadata --set com.apple.metadata:kMDItemFinderComment 'alfred:ignore' -- "/Applications/Utilities/Adobe Creative Cloud/ACC/Creative Cloud Helper.app"

 

Once I sorted that, all working fine now! ☺️

Link to comment
18 hours ago, luckman212 said:

the metadata was not actually being populated

 

Thanks for sharing this, but sorry to hear this macOS bug's rearing its head again  🤦‍♀️  (or maybe it never went away - Comments aren't a heavily used trick)

 

For users who are less keen on sudo command, I recall that setting alfred:ignore, closing the Get Info window, opening it to add a second tag, closing again, then removing the second tag was a ridiculous dance of force-updating that did the job as well.

 

I'm unable to confirm, as the comments are working as expected for me at this time, but the above is a lower-risk option for those who prefer not to use sudo commands. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...