Jump to content

File filter workflows stopped working

Recommended Posts

Hello!  Very simple file filter workflows no longer work. For example, I have one to search my Bookends Library folder. I type the trigger papersby and that pulls up the workflow, but then when I type space+filename, I get Google etc. searches instead. I tried downloading the sample workflow at https://www.alfredapp.com/help/workflows/inputs/file-filter/ and get the same error--seen screenshots.


I'm running Alfred 4.6.3  Build 1285, Tuesday 15th February 2022

Mac OS 12.2.1 (21D62)



Screen Shot 2022-03-18 at 4.50.15 PM.png

Screen Shot 2022-03-18 at 4.50.05 PM.png

Link to comment

@J_G Welcome to the forum :)


This could be caused by a couple of different things, so please take a look at the Indexing page specifically relating to Monterey:



The first step will guide you through using the File Troubleshooting tool to establish whether all the necessary metadata exists for your files.


If your issue relates to Monterey's Migration Assistant, then step 2 will sort things out for you.


If it doesn't, you may need to rebuild your Mac's index as outlined here:



Let me know how you get on!





Link to comment
  • 4 weeks later...

OK, I finally had time to go through the reindexing process. It didn't change anything--which not surprising, because there have been no problems finding files--the problem is running file filters.


Here is what happens when I use the sample PDF file filter you provide at https://www.alfredapp.com/help/workflows/inputs/file-filter/


1.  I type in "PDF":









2.  I select "PDF File Searcher":





3.  I type in the name of the PDF I'm looking for:








This is the problem:  the file filter disappears, and I'm given only fallback web searches.


Alfred has no trouble searching by file name, for example:





So it could be that I'm misunderstanding something basic, although I've used file filters successfully in the past. Or it could be an Alfred glitch. I'm running Mac OS 12.2.1  and Alfred 4.6.4  Thanks!

Screen Shot 2022-04-17 at 5.05.48 PM.png

Screen Shot 2022-04-17 at 5.09.45 PM.png

Screen Shot 2022-04-17 at 5.11.49 PM.png

Link to comment

@J_G The example workflow searches the ~/Documents/ search scope only, as per the tutorial above it. I can see that you're looking for files in Dropbox, which won't be included.


If you want to search any PDF files on your Mac, you'll need to edit the workflow and remove the set search scope.


Open Alfred's preferences > Workflows > PDF File Searcher, then double-click the File Filter object, go to the Search Scope tab and remove the Documents folder by selecting it and using the backspace key.


You'll now have a PDF searcher that will search anywhere on your Mac. :) 



Link to comment
  • 1 year later...

Hello, I've got exactly the same issue while I changed my Mac right now. All workflows with a "file filter" module do not work anymore... 


To be more precise, the only thing that the file filter finds is the "user" directory

Edited by zlebandit
Link to comment

@zlebandit Welcome to the forum. Could you please share your workflow (you can upload it to Dropbox or iCloud and share the link)?


If you launch Alfred's troubleshooting tool and drag in some of the files you're looking for, what does it report? You can paste the full output here so that we can also take a look.


The more details of what file types you're searching for, where they're located, etc you provide, the more easily we'll be able to help you work out how to create the right file filter for what you need :)



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...