Jump to content

introducing alfred-audible ūüéß


Recommended Posts

  • 1 month later...

I have checked these and they are installed properly

 

  • Alfred with Powerpack license
  • Python3 (howto¬†here)
  • an¬†Audible¬†account
  • pip3¬†installed (how to¬†here)

 

On running "audible-setup", I get following error message in terminal.  

sh audible_setup.sh

audible_setup.sh: line 3: audible-quickstart: command not found

 

I am using Monterey 12.3 and Alfred 4.6.7 Pre-release. Pls assist to troubleshoot. Thanks in advance

Link to comment
11 hours ago, giovanni said:

could you check the debugger? 

 

[06:09:03.944] alfred-audible[Script Filter] Queuing argument '(null)'

[06:09:04.078] alfred-audible[Script Filter] Script with argv '(null)' finished

[06:09:04.081] alfred-audible[Script Filter] {"items": [{"title": "Libraries installed! Press Enter to setup your Audible device \ud83d\udcf2", "subtitle": "will abort if already existing", "arg": "", "icon": {"path": ""}}]}

[06:09:11.924] alfred-audible[Script Filter] Processing complete

[06:09:11.925] alfred-audible[Script Filter] Passing output '' to Run Script

 

The error message is in terminal command which I posted earlier. 

Link to comment
Just now, pankajsz said:

user.workflow.BAC75A3D-F54F-4FA9-AA36-B3563E2E063B % sh audible_setup.sh

audible_setup.sh: line 3: audible-quickstart: command not found

 

Getting same error message. I will remove everything and try again.

Same error message after removing workflow and installing it again.

Link to comment
10 hours ago, giovanni said:

oh, I forgot to delete the lib directory within the workflow. could you try that (delete the lib directory) and run audible:setup again? I can fix the release later today

+--------------------+-----------------------+

I deleted lib and it went ahead with setup. After answering questions for setup, I get following error message:

 

I had selected country code as in

 

Do you want to continue? [y/N]: y

 

Login with amazon to your audible account now.

Uncaught Exception

Traceback (most recent call last):

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible_cli/cli.py", line 46, in quickstart

    sys.exit(ctx.forward(cmd_quickstart.cli))

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/click/core.py", line 781, in forward

    return __self.invoke(__cmd, *args, **kwargs)

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/click/core.py", line 760, in invoke

    return __callback(*args, **kwargs)

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/click/decorators.py", line 84, in new_func

    return ctx.invoke(f, obj, *args, **kwargs)

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/click/core.py", line 760, in invoke

    return __callback(*args, **kwargs)

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible_cli/cmds/cmd_quickstart.py", line 160, in cli

    build_auth_file(

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible_cli/utils.py", line 88, in build_auth_file

    auth = Authenticator.from_login_external(

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible/auth.py", line 482, in from_login_external

    login_device = external_login(

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible/login.py", line 556, in external_login

    oauth_url, serial = build_oauth_url(

  File "/Users/kpz/Downloads/Alfred.alfredpreferences/workflows/user.workflow.FE5FF2BB-A121-4C9E-9E84-B34C8F44A255/lib/audible/login.py", line 197, in build_oauth_url

    raise ValueError(

ValueError: Login with username is only supported for DE, US and UK marketplaces!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...