Jump to content

Setapp applications not showing in search since Ventura update


Recommended Posts

Prior to upgrading to Ventura I was able to see SetApp apps in Alfred. Since the upgrade they are missing. I've tried the usual steps (clear cache, rebuild Spotlight Index, check for updates, restart the app, remove and re-add full disk access permission).


Having searched similar topics I've also added /System/Applications and /Applications/Setapp to the search context.


Alfred version: 5.0.3 [2087]

MacOS version: 13.0


File search troubleshooting on an example shows the following:


Starting Diagnostics...

File: 'Renamer.app'
Path: '/Applications/Setapp'


Check file cache database...

File cache integrity is ok


Check if file is readable...

Alfred has permissions to read this file.


Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive


Check direct file metadata...

Direct metadata available

Display Name: Renamer
 Other Names: Renamer.app
Content Type: com.apple.application-bundle
   Last Used: 2022-10-26 21:08:34 +0000


Check mdls file metadata...

Metadata contains required items

_kMDItemDisplayNameWithExtensions  = "Renamer.app"
_kMDItemEngagementData             = {length = 11, bytes = 0x09000000005884c4410002}
kMDItemAlternateNames              = (
kMDItemAppStoreCategory            = "Utilities"
kMDItemAppStoreCategoryType        = "public.app-category.utilities"
kMDItemCFBundleIdentifier          = "com.incrediblebee.Renamer-setapp"
kMDItemContentCreationDate         = 2022-10-22 06:45:49 +0000
kMDItemContentCreationDate_Ranking = 2022-10-22 00:00:00 +0000
kMDItemContentModificationDate     = 2022-10-22 06:45:49 +0000
kMDItemContentType                 = "com.apple.application-bundle"
kMDItemContentTypeTree             = (
kMDItemCopyright                   = "(c) 2022 Incredible Holding GmbH All Rights Reserved."
kMDItemDateAdded                   = 2022-10-26 20:16:58 +0000
kMDItemDisplayName                 = "Renamer"
kMDItemDocumentIdentifier          = 0
kMDItemExecutableArchitectures     = (
kMDItemFSContentChangeDate         = 2022-10-22 06:45:49 +0000
kMDItemFSCreationDate              = 2022-10-22 06:45:49 +0000
kMDItemFSCreatorCode               = ""
kMDItemFSFinderFlags               = 16
kMDItemFSHasCustomIcon             = (null)
kMDItemFSInvisible                 = 0
kMDItemFSIsExtensionHidden         = 1
kMDItemFSIsStationery              = (null)
kMDItemFSLabel                     = 0
kMDItemFSName                      = "Renamer.app"
kMDItemFSNodeCount                 = 1
kMDItemFSOwnerGroupID              = 80
kMDItemFSOwnerUserID               = 501
kMDItemFSSize                      = 46643910
kMDItemFSTypeCode                  = ""
kMDItemInterestingDate_Ranking     = 2022-10-26 00:00:00 +0000
kMDItemKeywords                    = "files rename, renaming files, rename files, multiple rename, change a file extension, change the file extension, batch rename, renaming folder, batch renaming, batch file renaming, rename folders, renaming folders, batch rename of files, rename batch of files , rename files in batch, rename files batch, batch renaming files, multiple rename files, batch renaming of files, rename bulk, bulk rename, rename many files, file renamer, file rename batch, batch renamer, multiple rename files, Rename images, Rename photo, Rename photos"
kMDItemKind                        = "Application"
kMDItemLastUsedDate                = 2022-10-26 21:08:34 +0000
kMDItemLastUsedDate_Ranking        = 2022-10-26 00:00:00 +0000
kMDItemLogicalSize                 = 46643910
kMDItemPhysicalSize                = 47300608
kMDItemUseCount                    = 5
kMDItemUsedDates                   = (
    "2022-10-25 23:00:00 +0000"
kMDItemVersion                     = "6.1.0"


Check file is in search scope...

File exists within Alfred's default search scope


Troubleshooting passed

CleanShot 2022-10-26 at 22.32.42@2x.png

CleanShot 2022-10-26 at 22.38.28@2x.png

CleanShot 2022-10-26 at 22.40.31@2x.png

Edited by GerardK
Adding screenshot from Spotlight Search
Link to comment
Share on other sites

@GerardK Welcome to the forum :)


Taking a look back, this has happened in the past during a major macOS update, and settled very quickly for the few users affected with a rebuild.


You can rebuild your Mac's metadata index by following step 5 here (though I'd give it an hour or two if you've only just installed Ventura as it may settle by itself):



While Spotlight may appear to show results, this could be from an older cache, so please rebuild the index then type "reload" into Alfred and let me know how you get on.


Link to comment
Share on other sites

I have done every troubleshooting step and I'm still having issues with some applications. Most notably, Xcode, although I did have a little difficulty getting my aliases to Emacs to show up again, too.  Not sure what fixed that one exactly; I deleted and recreated them a few times, but there's clearly a problem. Applications inside the Xcode bundle also don't show up.  Spotlight can see it just fine.

Link to comment
Share on other sites

I've already rebuilt the Spotlight index using the method described in that page and performed a reload. I waited for the reindex bar to complete before running a reload and left it overnight and done a reload again. I've now repeated the process including revoking and re-adding full disk access permissions to both Alfred and Terminal in the process. The problem still remains.


Interestingly, there doesn't seem to be a .Spotlight-V100 directory in /System/Volumes/Data any more (I even tried sudo find /System/Volumes/Data -name .Spotlight-V100). I know that Apple have made some significant changes to Spotlight in Ventura so I wonder if the process for rebuilding the index doesn't work as before.

Edited by GerardK
Correction - .Spotlight-V100 is a directory, not a file
Link to comment
Share on other sites

@GerardK so here's a workaround that's working for me right now: find the offending application in Finder, "make alias", retitle the alias to the name of the original thing (since the file is named `.app` on the filesystem and aliases don't have an extension, they should exist side-by-side just fine), then go to Alfred, Features->Default Results->Advanced, drag the alias from Finder into the list (you only need to do this step once, since it adds the filetype and not the specific file) and try searching again.


This is obviously a janky workaround but it should at least avoid tripping over awkward finger memory while the bug gets fixed.

Edited by glyph
Link to comment
Share on other sites

@glyph Thanks for the suggestion. For now I've temporarily switched to another Spotlight replacement tool that doesn't have the same issue. I'd prefer to get back to Alfred though since it's a more keyboard-friendly app and I use workflows that don't have good equivalents in the competitor product.

Link to comment
Share on other sites

  • 3 weeks later...

I've been dealing with this for several days (had tried several recommended troubleshooting methods) and the only thing that ultimately worked for me was this


When I would try to reindex spotlight in the past, it was only taking 5 - 10 minutes. This process seem to do a more complete "reset" and now Alfred is picking up my Setapp applications again. As a side note, running "Rebuild macOS Metadata" from the Alfred preferences would give me an error about user being null on Ventura 13.0.1

Edited by jdavisbacon
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...